Server maintenance

Around Wednesday we will perform maintenance on the Panda3D site. The website will be migrated to a new server and the forum, wiki and blog software will be updated.

It will not be possible to access the website, download releases or make forum posts in the meantime. (The bug tracker and source code repository will stay up, of course.)
You may also have trouble using the web plugin for a while, but we will attempt to keep the web plugin downtime to an absolute minimum.

Apologies in advance for the inconvenience.

Currently having issues with the plugin. Should I assume this is related to the maintenance, and if so is there an estimate on when it will be functional again?

:downloader: [0x1012e00] begin GET [ ]
:downloader: [0x1012e00] Expired certificate from
Unable to download
Unable to load Panda3D plugin.

Coincidentally, the certificate just expired. We’re working on it. Couple of hours, perhaps?

Yes, the cert expired yesterday. It caught me off guard, since I get tons of emails when the /domain/ is about the expire, but not a peep about an SSL cert expiring. Puzzling.

We have a new cert coming from Comodo very soon. I expect within an hour, but certainly today at the very latest.

I have the cert, but trouble installing it. Comodo does something different with the interim cert. I’ve turned off SSL for now, so the site’s back up, but runtime download still broken.

I /just/ realized what I did wrong. In anticipation of the server migration, the key file for the cert I requested is on the new server, not the current one. I’ll copy it over, then all should be good.


New cert is installed. Please test it out.

rdb was still having trouble with the plug-in download, but it worked for me, so we’re not sure if it’s just a config on his end, or still something not right with the server.

I’m still getting the same error when running p3d files through the runtime.

Using the web plugin to run one of the online demos, a warning window pops up complaining about an expired certificate. It is possible to ignore the warning and run the demo.

You might have to clear out your Panda3D cache in order to observe this behaviour.

Thanks. Yeah, I definitely have installed a new, not-expired cert. The current problem is that SSL is complaining that there is a self-signed cert in the cert chain. We may have to contact Comodo if we don’t soon find that this is a blunder on my part.

But for anyone still getting the cert expired warning, yes, please Ctrl+F5, or equivalent, to clear your cache and try again.

Hmm, Panda plugin is still telling me the certificate is from godaddy and is expired. This is after resetting Safari and deleting my ~/Panda3D directory. Maybe something different between www.panda3d and runtime.panda3d?

Well, the p3d apps in the gallery are themselves still signed with the old certificate. I’ll get around to resigning those later.

It’s just the certificate on the site that’s changed. Does it still say GoDaddy when you go to

Ah, I see. Yes it is fine visiting the page itself.
I guess this certificate is included somewhere in the development tools too, and that’s why my own built version of ppackage etc. are having an issue?

I don’t know why the command-line panda3d is saying that it’s a self-signed certificate. It’s stumping me. Steve cannot reproduce it on his machine either.

That is the issue you were referring to, right? This one?

:downloader: [0xb87c00] begin GET [ ]
:downloader: [0xb87c00] Self-signed certificate from
Unable to download
Unable to load Panda3D plugin.

Yes, I get that one now instead of the previous expired message.

What operating system are you on?

That one was on OSX.

OK, yeah. The issue only seems to occur on Mac OS X for some reason.

In other news, we’ve delayed the migration until tomorrow in an effort to reduce the interruption to the services.

Thanks, rdb.

Yes, today we “practiced” the migration, and took notes of every step necessary. And, of course, there were a lot more than I remember. Details, details.

So, when I do the actual swap tomorrow (Thu) downtime will be minimal.

There is one step when in the upgrade script for phpbb3 that takes a while, no matter what, to process the Db. That part is probably 20 minutes on its own.

Well, if you see this post, then welcome to the new server. Changes include…

  1. New physical server, with Ubuntu 12.04-2 LTS.
  2. Forums’ phpBB2 upgraded to phpBB2 v 3.0.11.
  3. Manual’s MediaWiki upgraded to v 1.19-4.
  4. bLog’s WordPress upgraded to v 3.5.1.
  5. New SSL certificate from Comodo.