python.exe has stopped working


I am trying to install and use panda3d and I keep getting the error message “python.exe has stopped working”.

I have tried a number of the samples and I get what looks like a console screen with some text. It gets as far as and then the windows error pops up. I have also tried opening python in a command line window and added the line “import direct.directbase.DirectStart” before hitting “Enter”. This caused the same error to occur.

I have tried looking for a log file in “AppData|LocalLow|…” but there is no panda3d directory there.

I’m running win7 64 bit and installation of panda seemed to go fine. Does anyone know what the problem is or how I can fix it?

Apologies if this is a known problem that has been brought up before, but I haven’t been able to find any relevant information. Any help with this would be greatly appreciated.

Do you launch them from the Start menu or from commandline? In the second case, what is the exact command that you submit?

For the “same error” do you refer to the error message “python.exe has stopped working” or you receive a more informative message?

Thanks for the reply.

I’ve tried both. In the command line I tried (from the asteroid sample directory):


Yes, “python.exe has stopped working”

It’s very strange that from the Start menu it doesn’t work. But from commandline you should type a different command: can you try to launch ppython (note the double ‘p’, here for more informations)?

The double p gives me “ppython.exe has stopped working”.

Please, can you do this other test? From commandline launch ppython and in §python prompt type:

 import direct.directbase.DirectStart; run()

Done, gave me “ppython has stopped working” again. I forgot to mention earlier that I have also tried uninstalling and re-installing panda. Also I’m using version 1.7.0 of panda.

Can you run pview.exe correctly from the command-prompt? It should show a window with a blue triangle in it.

Just tried it, no it won’t run. I get as far as and then windows pops up “pview.exe has stopped working”.

Have you tried raising the Panda verbosity? What happens if you execute the following? Can you detect in the console the last message before the crash?

from panda3d.core import loadPrcFileData
loadPrcFileData( '', 'notify-level spam' )
loadPrcFileData( '', 'default-directnotify-level info' )
import direct.directbase.DirectStart

Ok, that gave me a lot of output. It didn’t get as far a run() but crashed on the line before. The last line in the console before the crash is again .

This is maybe a shot in the dark, but can you try the DirectX renderer? Set “load-display” to “pandadx9” or “pandadx8” in pandadir\etc\Config.prc.

I’ve tried all four of the available renderers, they all do the same thing.

Really? It even crashes with tinydisplay? Something is very broken indeed, then.

Can you show us the console output from pview after crashing while running tinydisplay?


Here’s the output from pview with tinydisplay:

This again produces a windows pop-up of “pview.exe has stopped working”.

This is indeed a puzzler. Something about Panda is unable to open even a simple window on your machine.

Out of curiosity, can you install the Panda3D runtime and run the Online Demos successfully? Or does that crash too?


I’ve just tried the online demos. Installing the runtime was fine and it managed to get the .p3d files. I got as far as a green, circular button with a right arrow in it (play, I presume). When I clicked this there was a slight hang and then I got a windows error popup saying “p3dpythonw.exe has stopped working”.

Thanks for all the help so far.

Well. Whatever’s going wrong, it’s pretty fundamental. Panda’s not doing much more than a CreateWindow() call, and boom.

I’m not sure how to proceed from here. Are you comfortable with C++ development? Would it be an option for you to download and build the Panda source and attempt to reproduce the crash in a development environment?


I am fine with C++, but I’m not used to the build systems. I’ve had a look through the documentation and its going to take too much time for me to understand how to compile it all at the moment. I should be able to try again next week though. Thanks,


I have to wonder if this user’s troubles are related.