Problem with Multi Texture in Particle

i try to make a multi texture sample with Particle Panel (Panda/samples/particles/Run Particle Panel) but have a problem with transperent …

with 1 texture all thing is fine

but with 2 texture, have some problem with transperent and border of texture.

I try all All Alpha Mode variable but nothing new.

Any body help me.

This is image source (

all image create with RGB mode

This is a problem in general with correct Z-sorting of transparent objects. See Transparency and Blending in the manual.

In this case, if you can’t move the particle systems farther apart so that they don’t intersect, the best solution may be to disable depth write on both of them.


Thanks David … I try your suggest and it works fine !!!
Thank you again :slight_smile: