Panda3D downloads for several distros


#1

Hello, I make this thread because I did some builds of Panda3D (SDK) and want to list them in one thread. All builds are 1.8.1 so far, if nothing different stated.

Debian 7 Wheezy 64bit (no artoolkit, no gles1/2, no bullet):
docs.google.com/file/d/0B5KBmyj … sp=sharing
If you need libRocket, you have to compile it on your own. libRocket support is enabled.

Ubuntu 12.04.2 Precise Pangolin 64bit (no artoolkit, no fftw, no gles1/2, no bullet):
This is an alternate build for the LTS enablement stack!
docs.google.com/file/d/0B5KBmyj … sp=sharing
libRocket:
docs.google.com/file/d/0B5KBmyj … sp=sharing

Ubuntu 12.04.3 Precise Pangolin 64bit (no artoolkit, no fftw, no gles1/2, no bullet):
docs.google.com/file/d/0B5KBmyj … sp=sharing
libRocket:
docs.google.com/file/d/0B5KBmyj … sp=sharing

Ubuntu 12.04.4 Precise Pangolin 64bit (no artoolkit, no fftw, no gles1/2):
This build is nearly full-featured and includes both libRocket and Bullet support!
drive.google.com/file/d/0B5KBmy … sp=sharing

Ubuntu 13.10 Saucy Salamander 64bit (no artoolkit, no fftw, no bullet, no gles1/2):
docs.google.com/file/d/0B5KBmyj … sp=sharing
the obligatory libRocket package:
docs.google.com/file/d/0B5KBmyj … sp=sharing

Ubuntu 14.04.0 Trusty Tahr 64bit (no artoolkit/vrpn, no fftw, no ffmpeg, no gles1/2):
This build is from the Trusty beta, if something changes I’ll roll out another build. This includes both libRocket and Bullet (for PPAs see below), but unfortunately FFMPEG changed it’s API so I’m not able to compile it. I’m sorry for that!
drive.google.com/file/d/0B5KBmy … sp=sharing

Ubuntu 14.04.0 Trusty Tahr 32bit:
The same things like 64bit apply for this build.
drive.google.com/file/d/0B5KBmy … sp=sharing

libRocket PPA
This PPA is new and I haven’t tested it yet! As every time, use at your own risk! Currently only for Saucy+Trusty.
launchpad.net/~joern-schoenyan/ … /librocket
Bullet PPA
Panda3D 1.8.1 needs an older Bullet than in the Ubuntu repos, so here is a Bullet PPA for Trusty.
launchpad.net/~joern-schoenyan/ … bbullet280

I will update this thread every time I add a new build. If you have wishes, feel free to ask - but I can’t promise anything.

Cheers!


missing ffmpeg (Ubuntu 12.04)
Ubuntu xorg corrupted after Panda3d installation
[SOLVED] Can I install Runtime insert SDK ?
Ubuntu 13.04 installation
Ubuntu 13.10 build
Ubuntu 12.10 - Can't install Panda3D
Building panda3D from source code.
autoshader:undefined variable "tot_diffuse" (w/ light ramps)
Installation on Linux Mint 15 fails 44% through
Prebuild precise package ruins xorg on 12.04.2
Not able to run programs after installation?
#2

Thanks a lot (particularly for debian wheezy)


#3

I hope everything’s running fine, I didn’t test it because I haven’t installed Wheezy, I did the compilation as everytime in a virtual machine.

** Update: I add the Saucy build to the list.


#4

** Update: 12.04.2 LTS enablement stack 64bit


#5

** Update: Arch 64bit


#6

I also have the arch build on AUR as well


#7

It is from your PKGBUILD :slight_smile: just precompiled with libRocket support and of course a package for libRocket.


#8

Oh sweet. How did you go about adding librocket?


#9

As your PKGBUILD has the parameter ‘–everything’, just installing libRocket with Python2.7 support is needed before making the build. For libRocket there is a PKGBUILD in the AUR, too.


#10

Today’s updates:

Ubuntu 12.04.3, 64bit
Ubuntu 13.04, 32bit


#11

** Update: added PPA for libRocket.


#12

Hi JörnS,

thank you for the compiles, I’ve been using them for 2 Ubuntu versions, latest being Saucy. I just have one request: building for Saucy Salamander 64bit with Bullet.

Please continue this!
Cheers,
wolfgangp


#13

Thanks a lot for this! I was having a hard time building Panda on Ubuntu Saucy 64-bit.


#14

Today I’m removing builds for Raring because it reaches End-of-life. Tried to compile for Trusty, but it doesn’t works - there are many issues. Not sure if I can provide a solution on my own. Will try it next week again, as I’m a bit busy this week.


#15

** Update: Added build for Ubuntu Precise 12.04.4 with the hardware enablement stack backported from Saucy. Includes both support for libRocket and Bullet!


#16

I tried to build panda3d and here’s the errors I got: http://pastebin.com/ERQbVdA2

Internal compiler error: segmentation fault in random places.
After running makepanda many times some of the source code that caused the compilier to seg fault were compiled.


#17

Hmm, the only case where I’ve seen that error is when my RAM was broken. Might want to try running memtest on it.


#18

** Update: added 64bit build for Trusty. 32bit coming soon.


#19

sorry if i sound like a noob but i installed both the files for 13.10 how do i run the programme now i dont have a shortcut rather new to linux :blush:


#20

Hello tetra184,

did you take a look at the manual? It’s a bit Windows specific, but you should get the point. There are also some quite exciting samples avaible here.