Panda3D downloads for several distros


#21

** Update: 32bit for Trusty.

Next on the todo list: builds from CVS. Should happen this weekend, I think.


#22

two weeks ago I have installed Trusty (14.04) and I am working now with most applications without any problem. My OS is 32-bit. I have installed libbullet280 and librocket and I downloaded 32-bit panda3d1.8.deb, but I have problem to install it. It means it starts to install and after short period it stops without installing it. Perhaps, I am missing something, alas i cannot tell what. I am installing panda for the first time. Pls. could you help me. Thanks in advance. :blush:


#23

Could you try this in the terminal:

sudo dpkg -i panda3d1.8_1.8.1_i386.deb

Of course you have to navigate to the folder where the download is before doing this. If it installs but complains about dependencies, you can fix it with

sudo apt-get -f install

If other errors occure, copy and paste them here, then we’ll look after it :slight_smile:


#24

Thanks for your replay. There were some updates for trusty. After this I tried to install Panda one more time, but alas with no luck. In some way it is installed, but is telling that it needs to be reinstalled. Ok, after this I tried the installation from terminal, also without luck. I made copies from both screens and integrated this in a PDF file. I will upload this file as attachment. Thanks in advance for your time. :slight_smile:


#25

Hi,

Thanks for the builds.
I’m trying to compile Panda on Mint 16 (Saucy base), and I ran into the following errors at the end:

/usr/bin/ld: cannot find -lRocketCore
/usr/bin/ld: cannot find -lRocketControls
/usr/bin/ld: cannot find -lRocketDebugger
collect2: error: ld returned 1 exit status
Process exited with exit status 1 and signal code 0
The following command returned a non-zero value: g++ -shared -Wl,-soname=libp3rocket.so.1.8 -o built/lib/libp3rocket.so.1.8 -Lbuilt/lib -Lbuilt/tmp -L/usr/X11R6/lib built/tmp/p3rocket_composite1.o built/tmp/libp3rocket_igate.o built/tmp/libp3rocket_module.o -lpanda -lpandaexpress -lp3dtool -lp3dtoolconfig -Lthirdparty/linux-libs-x64/rocket/lib -Lthirdparty/linux-libs-x64/rocket/lib/python2.7 -lRocketCore -lRocketControls -lRocketDebugger -lboost_python -pthread -ldl

I wanted to have a 13.10 build with Bullet and Rocket, so I tried to build it myself, but with no success.
Downloading for now. Thanks.


#26

Do you have libRocketCore.so on your system?


#27

OK, I solved it by a double install of librocket, one in the thirdparty directory of Panda source codes, the other one is from the .deb file by JornS.

It’s weird, but it worked. My first try was having only librocket installed in my system and makepanda didn’t find them. My second try was having librocket in the thirdparty directory of the Panda codes.

Thanks rdb. :slight_smile:


#28

I think it will be a good idea to update such pages for all operational systems.


#29

I’ve been playing around with Python programming for Panda3D under various Windows versions for a number of years, and thought I’d try to install it under Linux on the assumption it would run faster.
I’ve tried Panda3d1.8_1,8.1~quantal_i386.deb and Panda3d1.8_1,8.1~squeeze_i386.deb on Puppy Lucid 5.2.8 and the latest MINT 17.1 cinnamon 32 bit ‘Rebecca’. They fail needing versions of libavcodec and libavcodec-extra which don’t seem to be available even under the latest MINT.
Sorry if this is a naive question, but why is it so difficult to produce a generic install for Panda3D which works across many Linux distros? Blender installs under MINT fairly easily - I would have thought it was similarly challenging in terms of environment dependencies.
Is the only workable approach on Linux to recompile the Panda3D source code in a specific Linux environment? Seems a lot of additional and complex activity compared to Blender or the Panda3D Windows install!
Brian


#30

The problem is that distributions like Debian or Ubuntu require us not to ship the dependencies ourselves, but to use the ones from the package repositories. And if we compile Panda3D against libraries from the Debian/Ubuntu repository, we are locked to that version, so we need to make a different .deb for each version of Ubuntu.

Linux Mint 17.1 Cinnamon is based on Ubuntu Trusty Tahr, which can be downloaded in this thread. Alternatively, if you’re feeling adventurous, you can try this development build:
buildbot.panda3d.org/downloads/0 … 0620457df/
(Although it’s still missing a few minor things, including libRocket)


#31

Can you make one for 64-bit Debian Wheezy with bullet?


#32

I have an experimental 1.9 build for wheezy here:
buildbot.panda3d.org/downloads/8 … 790a2bacd/
It has bullet, but it requires enabling the wheezy-backports repository (which contains bullet).

It’s missing FCollada, libRocket, FMod, ARToolKit, VRPN, libsquish.


#33

rdb, would you please approve my Launchpad account ‘joern-schoenyan’ to the Panda3D team? I would like to refresh the packaging for the build dependencies, set up proper builds and some other stuff.


#34

That would be appreciated, thank you! Do give me a heads-up if you intend to upload packages other than the thirdparty dependencies, though.


#35

I thank you :smiley:

I did work on the packaging for squish (already compiled) and soon librocket will be in the PPA, too.


#36

Are you building them as static or shared libraries? The ones that are in there are compiled as static libraries (against recommended Ubuntu/Debian policies) because otherwise they would become runtime dependencies, which means Panda3D users would be required to add that PPA to their system’s package manager.


#37

libsquish is linked as a static library (as the packaging is still based on your packaging, just adapted to the new standards), librocket is indeed a shared library - should I change that?

In the mid to long-term, I would like to try to make proper packaging for Panda3D and then bring it to Debian.

EDIT: maybe an experimental PPA with shared libs would be an idea?

EDIT #2: basic Debian packaging is ready, but compilation stops early:

[T1] Building C++ object ../debian/tmp/usr/tmp/p3dtoolbase_composite1.o
[T2] Building C++ object ../debian/tmp/usr/tmp/p3dtoolbase_composite2.o
[T3] Building C++ object ../debian/tmp/usr/tmp/p3dtoolbase_indent.o[T4] Building C++ object ../debian/tmp/usr/tmp/p3dtoolutil_composite1.o
[T5] Building C object ../debian/tmp/usr/tmp/p3dtoolbase_lookup3.o

[T5] Building C++ object ../debian/tmp/usr/tmp/p3dtoolutil_composite2.o
[T3] Building C++ object ../debian/tmp/usr/tmp/p3dtool_dtool.o
[T3] Building Bison object ../debian/tmp/usr/tmp/p3cppParser_cppBison.o
[T1] Building C++ object ../debian/tmp/usr/tmp/p3prc_composite1.o
dtool/src/cppparser/cppBison.yxx:24:24: fatal error: cppTypedef.h: No such file or directory
 #include "cppTypedefType.h"
                        ^
compilation terminated.

#38

Solved most of the problems, now. Still needs a bit tuning, but I should be able to build Panda3D on Launchpad very soon!


#39

We used to have the Panda3D package built on launchpad. I may still have the rules files lying around to do that, I’ll dig around if it helps. I don’t remember 100% why I ended up removing it, but I suggest holding off from uploading the Panda3D package on the official PPA at this point.


#40

Sounds very reasonable. I will create an experimental PPA, so everyone can decide if he/she wants to try it or use official builds/compile it from scratch. I would be interested in the rules file, if you can still find it.