Materials aren't being applied when exporting to .egg

Beginner here, sorry if this a stupid question.

So I have this in Blender:

When I export to .egg I achieve this:

I want to apply the materials to the model, as you can see in Blender. What am I doing wrong? :frowning:

Well I changed to Blender Game and changed the materials.

I think it worked kinda?

Not as polished as the 1st screen though.

When you use Cycles to create a material, you’re creating a material that only Cycles can render. Cycles is a raytraced renderer, which is fundamentally different from a rasterizing renderer like real-time graphics APIs use. The screenshot you showed shows the ball realistically reflect light cast by the atmosphere, and it also shows ambient occlusion in gaps where light cannot get into easily.

We cannot export files that use material nodes. It’s only possible to set basic material settings (such as a subset of those provided in Blender Game mode) and then in Panda3D apply shaders that apply things like ambient occlusion and image-based lighting to produce an image similar to the raytraced image you are seeing in Cycles.

You might be interested in the RenderPipeline project, which implements real-time techniques like image-based lighting and global illumination. There’s a Blender exporter in the works that comes with a custom renderer mode which would allow you to set material settings and preview how the material will look when loaded into the render pipeline.

Also see the relevant forum thread.

Thank you :slight_smile:

I can’t make Ralph go the other half-side of the field:

EDIT: I’ve had to add the lines also to terrain, solved.

Other problem, I have nets on pview:

But loading the model:

Any fix for this?

I’m guessing this may be a transparency issue. Switch to Blender Game mode in Blender, then in the Material settings for your net, set the alpha mode to Clip:

You may also want to untick “Backface culling” so that the net is visible from both sides.

Unfortunately that didn’t work, I can see the net on the pview well but in game:

Solved it, had to change the alpha on transparency tab, it was on 0.