How to fix brighter fullscreen glitch?


#1

Hello,
when I run my panda game in fullscreen(from the config.prc)
my screen gets a lot brighter and that will make it ugly.
the codes in the .prc file are: fullscreen #t or fullscreen true (both don’t work)
even when I do the win-size to the max(max size pc screen(1920 1080) it will get the same problem.

anyone have a fix?


#2

Very strange. I’ve never seen that happen before.

Are you on Windows? Please try using base.win.getGsg().setGamma(1.0).


#3

Aye I will try.
one question, must the code be pasted in the .prc file or in the .py file?


#4

In the main file, where there is a base.run ()


#5

I know this is a bit late, but I see there was never a follow-up to this thread. This looks like it is the same as an issue that was fixed last november caused by NVIDIA drivers introducing 64-bit output targets and for some reason automatically enabling gamma correction on them, which is disabled by default in Panda:

It was fixed in the following commit:


#6

thanks all!
My reply is also late XD