Help with setting up IDE for c++ on linux mint

I need Help. I’m trying to use C++ on an IDE for Panda3d but always keep getting errors.

main.cxx:1:10: fatal error: pandaFramework.h: No such file or directory
 #include "pandaFramework.h"
compilation terminated.

how do i resolve this. Using Linux Mint 21.3 Cinamon and I have tried Geany and code::blocks so far.

Right now i am happy to use any IDE. Please guide me as i have no experience with these things.

Thank you in advance

I previously made a video, I think that in Linux Mint it will be similar, only you won’t need to set the path to the compiler.

Thank you so much. Will try this

EDIT. Doesn’t work. I changed the file path in the code. Still same error. Used both Geany and code::blocks

I don’t have a direct answer for you, but I might suggest looking to the following threads to see if any of the solutions posted there prove helpful:


In the ide, you need to specify a folder with headers.

and a folder with libraries.

But you must first make sure that they exist physically.