Getting error IOerror: could not load model files

Actually when I was running my simply without front end intergration with flask, the files runs successfully but now when I have integrated the my code with front end using flask, I am getting error. but I placed every folder and files at correct place as they were before

Perhaps you should put them relative to the interface executable.

Sorry bro, but didn’t get your point, could you please elaborate little, what should be done now?

What is your current directory in python?

basically in my anaconda prompt I’m inside FlaskProject folder
see in this image

I meant:

import os


this is current directory

Delete the extension .egg in the model loading line.
But no, it’s something else.

Yes I tried, getting same erroe again

But bro, when I was running my code without this flask integration part everything was working fine

what change should I do?

This is definitely not exactly a Panda3D bug. You need to find out what changes when you use the interface. And in general, explain what you are doing and why.

Basically my project is to convert 2D floorplan to 3D model.

Initially I was running file in anaconda prompt and it runs successfully and since this project code is written in python 2.7 so I created a new environement in my prompt for 2.7 version. But now while integrating with my front end I pasted all the python file and folder from rendering folder to my FlaskProject folder and running flask run in my prompt

This is where I am getting error

Can you show us the full file-path (excluding an personal identifiers, if you prefer) for:

  • The working version of the model-file
  • The working version of the program
  • The non-working version of the model-file
  • And the non-working version of the program

I’d like to see whether there are any relevant-looking differences between the paths and their relationships with each other.

This are versions of all I’m using

wait a sec I’ll send the path

The path for running the code in prompt:
(newenv) C:\Users\jacky\OneDrive\Desktop\FlaskProject>
The path where those .egg file exist
The path where my viewer.file is

All right, and what were the paths when the program worked?

The path for running the code in prompt:
(newenv) C:\Users\jacky\OneDrive\Desktop\Floorplan\rendering
The path where those .egg file exist
The path where my viewer.file is