GeForce 6100 nForce 405-Shader Random

In my WinXP(GeForce 6100 nForce 405 - With last drivers-PANDA3d opengl mode) Shaders Samples(Tron) run ok, or run with no Shaders(off ?) or Shader on/off many times random.

Change settings in Nvidia control panel not solve the problem.
any ideas?

That is most likely related to this:
So the solution would most likely be to explicitly apply setSort to all the texturestages.

If this applies to one of the sample programs, that would be like a bug in the sample programs indeed. Can you please tell us what version of Panda3D you are using and what sample program it applies to?

Panda 1.5.2. (Try reinstall not solve the problem)

Applies -Glow Filter Advanced and this forum sample:

Thanks pro-rksoft. Testing setSort.

With setSort or setPriority Glow effect run for one second, and turn off.

Test in “Panda effects cookbook” :

New test:

In “Panda effects cookbook”
comment the sequence of earth rotation:

#self.interval = self.model.hprInterval(20,Point3(360,0,0))

The sample start with glow ok, after 1-4 seconds, stop glow and the earth
disapear! :open_mouth:

Last test: In full screen, “Panda effects cookbook” run OK!