Game: Night River


#1

I’ve just released a little side-project of mine: a short, simple, spooky, freeware experience called “Night River”.

Boat down a black-glass river, and encounter a series of ghosts along the way.

Game link: https://thaumaturge-art.itch.io/night-river
Trailer: https://www.youtube.com/watch?v=WKYBasXoIhc


#2

To ensure that the window does not go beyond the screen, you can change the fullscreen #f line to fullscreen #t in the game.prc file.

However, I cannot set the window size to equal the resolution, because most likely it is blocked in the WindowProperties () code. I would like to say that you @Thaumaturge should not do this in this way.


#3

As I recall, I’ve had problems with going to full-screen before, especially under Linux (which is the platform that I develop under). Wanting to keep things very simple for this project, I decided to simply leave the window decorated, and let users size it to their liking (barring the removal of the decorations).

For my main project, I am using an undecorated window, and a drop-down by which to select a resolution.

I’m not quite sure of what you mean by this. Can you not resize the window, or even maximise it? The only parts of the screen that should be left out of the window then would be the decorations (title bar and borders)–none of which should be related to the “WindowProperties” code.

(I think that, for this project specifically, it might have been a better idea for me to have had the window default to a smaller size–one that’s less likely to bump into the sides of the screen–and then once again rely on users to scale it to their liking.)

Either way, thank you for trying the game, and for your feedback! I appreciate it. :slight_smile:


#4

I mean what I set the native size of my screen and turned on the full screen:

win-size 1920 1080
fullscreen #t

I received (note: only the window in the center, not in the corner, OBS put it there):

As far as I remember, this problem was with Panda3D. But I think it was fixed.


#5

Wow, I very much enjoyed this. I’m impressed. Well polished, too.

I would agree that having a fullscreen option would add to this game. Perhaps it could simply be off by default, but be enabled via an option in the options menu. I think that on Linux you shouldn’t have trouble switching to fullscreen especially if you set the window size to base.pipe.getDisplayWidth()/Height() so that no resolution-switching is needed; do file an issue report if you experience otherwise!

I tried plugging in an (Xbox One) gamepad at the main menu, but it caused the cursor to switch erratically between the options; I suspect that this is because the Xbox gamepads don’t properly report a value of 0 when they are centered. I would suggest that for directional controls like in menus you build in a considerable deadzone, so that eg. only inputs of 0.3 or greater will trigger a switch to the next menu item.


Fullscreen acting up with dual monitors
#6

Ah, I see! Thank you for elaborating!

I suspect that you are indeed correct: I’m setting a window-size in code, which is presumably overriding the value that you’re (if I take it correctly) setting in the config.prc file. I honestly didn’t expect anyone to edit the file to set full-screen! ^^;;

Thank you very much! That’s great to read! :smiley:

Hmm… I could perhaps look into it. That window-size snippet may be helpful! I’ll give it some thought, thank you!

I think that a lot of the trouble that I have is due to the fact that I have two monitors. This seems to result in some odd behaviour: in short, the system seems to behave as though I had one huge monitor, with very limited resolution settings–despite the system’s display settings reflecting two monitors, each with their own resolution!

As a result, querying the list of resolutions (via “base.pipe.getDisplayInformation()”) returns only a single, huge resolution, and attempting to go to full-screen results in the following error:

:display:x11display(error): Videocard has no supported display resolutions at specified res (1366 x 768)

–Even on the monitor that has that resolution!

(It does seem to enter full-screen mode, however–although I’m not sure that it really does so, as I’ve seen cases of the backdrop poking through at one edge or another–and I don’t know at what resolution it does so.

I think that I’ve seen mention of this issue elsewhere–it seems to be a Linux (or perhaps Ubuntu; I’m not sure) thing, rather than a Panda thing.

I actually did set a dead-zone–but it perhaps wasn’t large enough! I think that I use a value of 0.01. 0.3 is surprisingly high!


#7

I’ve just posted a bug-fix update, with the following changes:

  • The placement of the game-window should be more reliable now.
    • I’ve reduced the “default resolution”, and changed the settings in my config file.
  • Gamepad thumbsticks should have a larger dead-zone, making them less twitchy.
  • Resolution changes in the config file are no longer overridden by code.

As before, you should find it here: https://thaumaturge-art.itch.io/night-river

(I’ve left out fullscreen support for now, in light of the issue with handling resolution-switching and fullscreen under Ubuntu. See this issue for details.)


#8

I’ve just posted a feature update: Night River now has a Korean translation, as well as fullscreen support! :slight_smile:

(The translation is very rough; it’s an amateur translation by myself.)