im going to generate couple of 100 sounds. but as im running a test, i got a strange effect. i cant play more then max 5 sounds, if im using more, some sounds arnt playing or i got strang distortions. is this related to fmod or to my hardware?

You are probably hitting the max number of hardware channels of your sound card, which is weird, because fmod, being a commercial quality engine should have a software mixer, maybe there’s a way to enable it?

EDIT: Nah, try this configuration directive “fmod-number-of-sound-channels 128”

Also, could you try OpenAL with that many sounds while you are at it? (Using CVS version, cause it fixes a bug.) I would be interested in knowing if it explodes or something.

seems really to be a hardware problem :frowning:

i tried the irrklang libary too.

Did you try “fmod-number-of-sound-channels 128”? Sound cards do have a limited amount of channels, but any decent sound engine should be able to software-mix sounds when getting out of available channels. Although the origin of the limitation may be hardware related, I don’t think it’s a hardware problem per se. Also, have you tried OpenAL with panda?

Also don’t draw conclusions from irrklang, last time I checked it was a very lightweight library that relies on the backend (like directsound on Windows) for most operations. It wouldn’t surprise me if it didn’t mix sounds.

EDIT: I did some checking, Fmod has a premixer, openal and irrklang don’t. Openal however should support 32 concurrent sounds at least, which is all you need, because more than that will be too cpu-intensive even for fmod. What platform are you on?

do you think im not listening to you :smiley: ? of course i insert 128 channel instruction into the config. i really think its related to my hardware or drivers!

Yeah sorry, just making sure you didn’t miss my edit. You should be able to play up to 256 sounds in OpenAL. Can you try? You’ll want to get the CVS version first, (fixes that bug you posted about) but that isn’t necessary if you just want to test this. Also you need to have done the steps I told you in that thread to update the openal dll.

same reaction with openal. anyway, i put this optional into my game.

Ok, just making sure: are you telling me you can play exactly 5 sounds maximum with openal, fmod and irrklang? Note that with openal you need the updated dll to play many sounds, it’s not optional.

this could be the reason, i just tried it with python with the recommended dll which is coming along with panda, but where do i get this dll? or where do i find in overall newest source of panda,
i cant find any new version at this link. this is maybe a silly question,but most of the things there are 9 or more months older?.

No, remember this procedure? … 3295#53295

Just do what you were doing in C++, but switch to openal and update the dll like explained there. Also use the cvs version if possible so that the 5-seconds bug is also gone (been fixed for 3 days.)

ok, i made now all changes. but i cant compile panda in vs. i downloaded the thirdparty package, but i still got this error while compiling, the thirdparty directory cant be found. i tried to define the define the python.exe, but im getting this error ~no debug information cant be found.
also if im trying to build it in debug, i got the error its searching for python_d.exe i tried to rename the python but im also getting the same error.

and please take a look in this both files, just prevent that i dont have to ask again. at one or two lines i wasnt sure.

Those files seem malformed. Just delete them and cvs update to get the last ones. The current ones have the patch.

You have to get the thirdparty package for windows and put the thirdparty folder it in your panda root dir. If you have windows 64 you will also need to copy win-python to win-python-x64.

pardon lol(i just followed your instruction :wink: )^^? no please say me which lines are wrong there! i wasnt sure at line 228. it was really hard to follow your malformed changes. :wink: some things was really far away from any logic. first off i had to going to do the changes upside down, that i can stay in the line order. and some line change ordering was pointing into a comment. :wink:

and please, say me :smiley: where can i download the latest cvs. if you wont answering me now. i never will ask this again. i think three times are enough. :wink:

oh and just in mind, please say also, how to get over this error in vs. :slight_smile: im sure this one will also stay, in the newest cvs version.

ok, i will answer this too, yes, im having the thirdparty package in my panda “root” i would call it just directory. :wink: where should it else to be?

I think you are confusing issues here. You were trying to manually apply a patch. That diff was a patch file, it’s meant to be applied automatically, they are not instructions. Completely forget about that. Those files you linked to are malformed, apparently you tried to apply the changes by hand but just got confused, just discard them, please.

Yeah, I didn’t understand you the first time. And don’t make a big deal of it, you just asked once before, don’t count an hypothetical third just to make it sound like I ignored you several times, thanks.

Follow instructions here regarding cvs: … on_Windows

No, see above. You just need to stop messing with files and get a cvs version. This is the last cvs version:

      } else if (len == 0){
         return true;

And this is your file:

      } else if (len == 0){
         return true;
      _packet_data += len;

So yeah, I’m pretty sure there are differences.

you said you get “the thirdparty directory cant be found” so naturally I tell you where it goes. As I already said, you need to copy the python dir if you are in windows 64, or you will also get that error. did you do that?

yes true, maybe i deleted by pasting your code a clamp, but im sure this one i had saw :wink:. i did really quick this change. of course there is a instruction, you post it. :smiley:

oh i see, you changed a bit your instruction in the meantime :wink: anyway, i dont wanna make a big deal out of it, i just want this thing running.

thanks for the link. the first time was, where i stayed in silence. :wink:

but this is really very anyoing!

so i downloaded now all. let me see if it works this time…

forget about my anoying statement. i was missunderstanding it. i thought the directory have to be in the panda root, and that is it. not that i have to execute the command from the root.

Eh, exactly as both the error and the makepanda documentation state, you need to invoke it from the root:

cd D:\panda3d-1.7.0

yes i know it in the meantime, i just understand at first, before i was reading the manual, that the directory have to be in the root. but makepanda\makepanda.bat cleared it for me.

but sorry to say :frowning: a rc.exe file is missing (rc = remote computer)? or what is this rc.exe?

You should run makepanda from the Visual Studio 2008 Command Prompt (you can find that somewhere in your start menu, I think)

but before, i wanna know what is doing this rc.exe file?

rc.exe is the resource compiler of visual studio, it’s used to package data files like icons and bitmaps into executables.

if you execute makepanda from the visual studio 2008 command prompt, makepanda will find it.