Exporting Texture Issues

For some reason when I develop a model in blender with a texture, the YABEE exporter does not want to export. What could be wrong?

You can specify which YABEE exporter you are using. And also please demonstrate the settings of the material nodes.

Im using the YABEE file named “YABEE-1-devel” by Andrey (Nineth) Arbuzov

I know only one version of YABEE that was provided by the person you specified.

And it does not support blender version higher than 2.7

Regarding the material settings, I meant the node tree. It is located on the Shading tab

Thats the one
Here is the node tree:

Everything is fine with the material settings. It is not clear which version of YABEE you are using…

That is the link I used to download YABEE. I have already been able to export 3d objects without textures and 3d animations without textures

Hey Richard. Portions of it may work abd portions of it may not. Depending on its support. I know ive ysed maxwells yabee to success and have also submitted some bug

1 Like

As noted by serega, above, I don’t think that the version of YABEE that you’re using supports versions of Blender beyond 2.7, and judging by the screenshots, you would appear to indeed be using a version of Blender beyond 2.7.

I’d suggest then looking into the Maxwell version of YABEE mentioned by CeyaSpaceCowboy–see the link below:

Thank you the new download seems to be exporting the texture. However, the texture still does not appear when I self.render

For the record, it would likely be easier to help if you were to upload the actual egg-file, rather than a screenshot of it.

But yeah, as far as I see the texture isn’t referenced in the egg-file. How are you applying it in Blender?

I am applying the texture without nodes since with nodes has an export error.

I don’t see a texture there–just a material. Is that what you mean–that you have a material applied that you’re not seeing?

Which exporter are you using?

Sorry wrong screenshot. I’m using the YABEE from the link above for blender 2.9 I have blender 3.4. should I download an older version?

Sorry for the repeat question, running on low sleep. Since you are using maxwell yabee, your issue is likely the one i submitted a pr for. Please see this the only open pull request and go ahead and grab that fix. You can change the line of code yourself in the blender addon folder.

sorry, I had trouble following, how would I open the pull request and what should I replace the damaged line of code with? from one of your previous posts, I tried to modify the code:
for node in nodeTree.nodes:
if node.name == “Principled BSDF”:
principled_bsdf = node
basecol = list(principled_bsdf.inputs[“Base Color”].default_value)
metallic = principled_bsdf.inputs[“Metallic”].default_value
roughness = principled_bsdf.inputs[“Roughness”].default_value
However, when I rezipped the file and tried to install the add-on, it was not showing up even though it says the add-on was installed

To open the pull request, go to the GitHub repository for Maxwell’s version of YABEE (i.e. at this link). There, click on “Pull requests” (near the top), then on the entry titled “Custom Properties Tag Support”. Finally, in the page thus opened, select “Files changed”, which should show the changes being suggest in the pull request, with the old code on the left and the new code highlighted on the right.