Blender 2.49 Chicken Installation Problem

We’ve just downloaded panda and tried out the first few examples and now are having difficulties exporting eggs from blender.

We are using OSX 10.5.8, blender 2.49b, chicken R91, (panda 1.7) and seem to have some kind of chicken installation error.
The chicken export option comes up in the menu, but only gives us a puzzling ‘blank’
dialogue box for options that seems to stretch off the left of the UI. There are two ‘options’ neither of which seem to do anything.

I have been reading around your forum and have tried a few things out like moving the .py files into the actual designated blender default scripts folder, deleting them and re DLing them straight to that folder and unpacking there, and also reinstalling blender itself.

Heres the blend

Can anyone help please?
Alternatively should we be trying to learn a blender 2.49/2.5 > Collada pipeline instead?
Any advice on how best to proceed much appreciated.


To get the easy stuff out the way - your .blend file looks fine and I wouldn’t go down the Collada route, at least not yet.

As for the problem your having I’m going to need more information. Could you run Blender from the command line so that you can see its logging output, and c&p it to the forum? I’ll warn you I don’t have access to a mac, so it can be quite hard to work out what is wrong in these situations.

Thanks for your reply. :smiley:

I will definitely get back to on this lethe, but for the moment I am getting absolutely nothing in terms of logging output!

Ok after another try, some info popped up in the

sigh no c&p apparently…hope an image is alright!

I vaguely understand that…malloc is C, is this an unassigned pointer being freed?
Does that mean Blender then, as opposed to chicken?
Scratches head


That is not what I am after, and I very much doubt that is anything to do with it - Google tells me its some kind of mac specific scripting language, and Blender doesn’t do anything mac specific being that it is multi-platform.

Can’t really help much with running Blender on the command line - its not something I know how to do with a mac, but I think, though I am not 100% sure, that the .app file for Blender is actually an archive of some kind that contains the executable as well as its data - maybe if you could extract that archive and run the executable directly from the command line rather than via the open command you would get some feedback.

ok thanks…

One thing after another…
The .app indeed has a blender inside it.
./blender runs it, but it seems the OSX will not give it the focus…ie neither tablet nor keyboard makes any effect on blender, and blender doesn’t show up when alt-tabbing.

I will have another look at this later, but for now I have to had over the laptop to my son

Ok have blender running via the command:


…but so far no terminal/console output from it when trying to run chicken.

Any other ideas?
Thanks for your time. :slight_smile:

If I put and, and the chicken folder with the UI .pngs into the srcipt folder
then when i try to run chicken I get:

dyld: Library not loaded: libp3dtoolconfig.1.7.0.dylib
Referenced from: /Developer/Tools/Panda3D/egg2bam
Reason: image not found
Configuring chicken, script is /Applications/
Traceback (most recent call last):
File “”, line 1, in
File “/Users/stuartdunstan/Documents/ShogunX Blender/scripts/”, line 2238, in
AttributeError: no such file or Blender text

Well, there is your problem - Panda isn’t working, and Chicken requires a working Panda. (You can confirm this by running egg2bam from the command line.) That error is one I’ve seen before from Mac users - I don’t know of a specific solution for it, though you can search the forums to find various instances. Changing Panda versions seems to have worked in some cases - maybe try a buildbot build? Other than that maybe one of the Panda users who had that problem could help you - it would be useful to have a specific post in the forum somewhere that gives the solution!

Try installing the latest buildbot release of Panda3D.

Should I delete any of the old panda dirs first, or does it just overwrite that?

Should be overwritten.

I seem unable to download from here:

Am I looking in the wrong place?
I can right click>save as and get a file, but these are tiny and fail to mount.


You don’t have permission to access /buildbot/builds/Panda3D-2010.11.04-13.dmg on this server.

Sorry about that. Resolved - try again.

Sorry rdb, I am still getting:


You don’t have permission to access /buildbot/builds/Panda3D-2010.11.06-16.dmg on this server.

…with both firefox and opera.

Beh. I wonder why the umask isn’t working.

Regardless, it should work now. Sorry about that.

Download in progress.
This’ll give the boy something to gnash on later. He’s currently making yet another fps in BGE and wants the laptop back already!

Thanks for your help! :slight_smile:

Panda reinstalled, but still the same business with chicken/eggs…

No output in terminal, I will try moving .pys around and try again.

Dragged,, and the chicken folder out of the chicken_exportR91 and into the scripts folder proper…and we have chicken!! :slight_smile:

Instructions up in terminal, ending with:

Settings for export not found. Using defaults.

Teh chicken has laid an eggski!!

(Now the Mrs is talking about getting IRL chicken coop + chooks again…really…doesn’t she know the relative merits of getting software working vs eating!?!)

And there it is!
Thanks for your help folks, now we need to get on and add a texture and learn the ropes.

Stuart and boys.

If you have to mirror anything in Blender… Don’t! It’s best to export the object, mirror it by means of another 3D application and then import it back into Blender.

Using Mirror on an object directly from blender, then directly exported through chicken, will cause lighting issues with that object, in Panda. The only way to correct the light then is to set that object as solid instead of smooth. Solid objects are slower, first of all…and secondly, if it’s a character you don’t want it looking like a block robot.

I don’t know if the Blender Developers even know about that problem. It’s a hard one to swallow; I’m still rebuilding an entire animation data base because I didn’t know about that issue with Blender.

Don’t want to see anyone else sitting on the same thorne the way I did…it’s still hurting my “arse.” :laughing: