Blend2bam not converting textures

I’ve tried using blend2bam to convert my blender models to bam models, but the textures don’t seem to load. I there any way to load the textures, or do i have to do something to the model itself?

Strange. It works perfectly for me. Where is the texture file?

Did you add the textures- flag onto your command?

Without more info, or seeing the model, it’s hard to tell what is going wrong. In some cases, the material is not set up in a way that Blender’s glTF exporter supports, which is a common cause of such issues (blend2bam uses the glTF exporter under the hood). Be sure you are using Principled BSDF for all your materials, also.

I do see now how linking the files would indeed be helpful, however I’m flagged as a “new user” so I’m not allowed to upload my files. I have tried the --textures flag, however it yields the same result (a black and white, oddly shaded model) with the text:
“Warning: mesh Cube.002 has a primitive with no material, using an empty RenderState” printed in command prompt

Please take a look at the Materials section of the blend2bam conversion guide and make sure that you’re following the guidelines laid out there. I suspect the material is not setup correctly in Blender for the glTF exporter since the intermediate gltf file appears to be lacking a material.

ok, thank you!

Thank you for your help, now I can continue making my monstrosities! Thank you for your help, and your glorious converter. (and I’m no longer flagged as a new user yay)

I’ve come across the same issue. I’m using blender 2.79 and blend2bam, but all i’m getting is a completely textureless (white) model. I’ve made sure that the model lives up to the guidelines but it simply doesn’t seem to work. I’ve also used the --textures copy flag but that doesn’t seem to make a difference. I really need this to work, so any help would be amazing!

Terminal output:

sjoerdv@penguin:~/python/projects/Lander controller$ blend2bam --textures copy lunar_lander.blend lander.bam
Read prefs: /home/sjoerdv/.config/blender/2.79/config/userpref.blend
path not found
RNA_def_property_ui_text: ‘Use loop normals created by applying ‘Normal Edit’ Modifier as vertex normals.’ description from ‘opt_use_loop_normals’ ‘’ ends with a ‘.’ !
path not found
srcroot: /home/sjoerdv/python/projects/Lander controller/
Exporting: [’/home/sjoerdv/python/projects/Lander controller/lunar_lander.blend’]
Export to: /tmp/
Read blend: /home/sjoerdv/python/projects/Lander controller/lunar_lander.blend
path not found
Converting .blend file (/home/sjoerdv/python/projects/Lander controller/lunar_lander.blend) to .gltf (/tmp/lunar_lander.gltf)
Blender quit

Blender file:
lunar_lander.blend
lunar_lander.blend1

AFAIK you should use Blender 2.80+ for blend2bam.

So that’s the issue… Any idea on how to get .egg or .bam files outta blender 2.79?

yea i’ve used that as well but it gives me an error inside blender. The exported file only contains one line :confused:

YABEE works with 2.78 and before, I believe; I think that 2.79 is the first version that it doesn’t support.

So is there anything that does work for my situation?

I’m afraid that I don’t know; I still use 2.78 and YABEE.

Get new blender? Btw your model doesnt have textures, only materials. I tried to export with B2,79 lunar_lander.egg (2.2 MB)
I think you cant use blender nodes for the materials tho? Im not sure. @Thaumaturge ?

If I recall correctly–and I do stand to be corrected, as I don’t use blend2bam–you can use nodes with blend2bam as long as they’re set up in the way that it expects. I don’t know a lot about the specifics, but you may find them if you search the forum.

I used YABEE.

@Pignon that model you exported still has no texture :confused: