ATI Antialiasing

Hi all,

I like using antialiasing in my games, and I have been happily using multisample antialiasing for the last few weeks with my NVIDIA graphics card.

Today I just upgraded the computer to a later ATI card, however, my game now does not display any antialiasing even though I have it switched on in the config file.

My config file has the following:

depth-bits 1
color-bits 1
alpha-bits 0
stencil-bits 0
framebuffer-multisample 1
multisamples 4

Is that all I need to do to enable MSAA? As I said it works on my NVIDIA card but not my new ATI one. Is this perhaps a bug in Panda3D? Does anyone else have an ATI card (my new model is the Radeon HD 5850) with antialiasing working?

Thanks in advance :slight_smile:.

Hmm, I think that should be sufficient. You can prove that multisamples were enabled in your framebuffer by printing; it should include “multisamples 4” or whatever.

Assuming it does, but you still don’t have antialiasing, try explicitly enabling it with something like:



Interestingly, when I call getMultisamples it returns 8. It returns this if I set it to either 0, 2 or 4 samples. I have checked all of Config.prc and there is only 1 line that I am setting the number of multisamples. I am also definitely not setting it explicitly in the program.

This is very strange, any ideas? I can post any more information if you need it.


i have a (very old) ATI-card inside my machine and antialiasing works fine…

This is not at all strange; it’s normal. Asking for “multisamples 4” is just a minimum request; your graphics driver might (and commonly does) provide more than the minimum requested.


Thanks again for the responses.

@David: Ok, that makes sense. So the game at least thinks that it is set up to use antialiasing. I have tried enabling multisampling on the root node “render” but it doesn’t seem to have any effect, there is still no antialiasing on the scene.

Hmm, maybe I should see if I can force it at the driver level.

Maybe it only works when in fullscreen.

Thanks for the suggestions. Unfortunately I have been mainly running the game in fullscreen and it makes no difference.

EDIT: Although I have 2 monitors and by full screen I mean maximising in one of them. The other one remains empty.

EDIT2: However, after disabling the second monitor and testing it made no difference. Still no antialiasing. I know AA works because I can get it working in other games like TF2 and Sam and Max. Forcing AA settings at the driver level for my game also doesn’t work. However, forcing it for splinter cell also doesn’t work so maybe it is related to the card and the way the renderbuffers are set up.

Maximizing it is not full screen. Full screen means that it will fully take up the screen with no window decorations. I believe it uses a different pathway for drawing than in a window. Also most games that I know of will not do AA unless in a full screen mode so there is probably some hardware or driver limitation in that regard.

Yes, sorry, I probably shouldn’t have used the word maximising in that context. What I am doing is true fullscreen, there are no window decorations. What I meant was it is just fullscreen on one of the monitors, not stretched across both of them. However, I think this is fairly irrelevant as antialiasing works on most of my other fullscreen games when only being fullscreen on one monitor.


AA works on my HD4670, even in windowed mode.

Hmm, lots of other people have it working. I wonder if it is a driver issue for my particular card? I don’t suppose anyone else has a HD5850 with working AA?

I am really struggling to debug the issue, Google hasn’t really yielded any results for problems with antialiasing on the HD 5850. I think that I have set up the game correctly, because it worked on my old NVIDIA card and none of the samples that come with Panda work with antialiasing on my new one. I know that the card doesn’t completely fail at doing antialiasing because there are a number of other games that I play that it works for. I am unsure of what else to try :frowning:.

Hmm, so after doing some more digging it seems that the HD 5xxx series ATI cards have a few antialiasing bugs in the drivers. Some games seem to not work with antialiasing, and the Panda3D engine seems to suffer from the same issue. I guess I’ll just have to wait for a driver patch.

I have a Radeon HD 5750 and anti-aliasing works great in Windows 7 but does not work in Ubuntu 9.10(and presumably 10.04 as well).

I recently got a new laptop and loaded it up with Ubuntu 10.04. It has an integrated Radeon HD 4200 and I have not been able to get anti-aliasing to work on that either.

Do you guys know if this is just a problem with Ubuntu/Other Linux Distros? Not really a big deal for me but just kind of curious.

Chompy, do you mind if I ask what version of the catalyst drivers that you are running? I am still unable to get antialiasing to work with my HD 5750 on Vista 32bit. I just updated to the latest drivers this morning and still nothing.

If everyone else has antialiasing working then that implies that it is something specific to me. But antialiasing works on all my other games, just none of the Panda3D games or samples.

Hi all,

Still having trouble with this. Is there any way that I could provide the developers with information to see if there is a problem in the engine?

I am running an ATI 5850, and I have 2 desktop monitors. I am extending my first monitor with the catalyst control centre so that it is effectively 1 big screen, I’m not sure whether this will make a difference to anything. I have tried disabling it in the drivers but it makes no difference to the end result.

I am running the latest drivers. I have tried setting the flag to auto in the render graph and switched it on in the external config file (“multisamples 8” and “framebuffer-multisample 1”). I am completely out of ideas and it is driving me crazy.

The problem occurs both in my project and all of the samples that come with panda3d.

Thanks in advance for any help.

Do these work properly on yours :

Yes, both of those programs work perfectly without problems. As do all my other games. It is just Panda3D based applications that I am having problems with.


Sorry neutrix! Haven’t been checking the forums a lot.

I am currently running Catalyst Control Center version 10.6. I doubt it makes a difference but I’m running Windows 7 64bit. I also run dual monitors.

If no one has suggested this already you might try forcing anti-aliasing through the CCC. Also, have you tried running Panda3D using Direct3D 9 as opposed to OpenGL?

One last suggestion… Catalyst A.I. set to Expert has cause some strange problems for me in the past. If it isn’t already keep it set to Standard.

Probably not it but worth a shot if you haven’t tried them already!

Are, perchance, all your “other games” DirectX based? Do you have any OpenGL game with AA that works for you?

If so, have you tried running Panda in DX mode as the poster above suggested?

Btw somebody posted 2 GL demos above, it seems the first one doesn’t use GL_ARB_multisample, so focus on the second one, though I haven’t read what they do, but just test both, but above all test panda in DX.