An access to a high graphic 3d games


#1

Hello all…
This thread should have been added 2 weeks ago but the troubles in Egypt affected me badly

I talked about the idea of making a high quality 3d game in a thread before:
[High quality graphic within game??)

I started working for about 2 months to achieve this idea in a 3d point & click game(which is my favorites)

The example here is a sample for what I made, using eve as a character , blender to create room and objects then made an algorithmic finding path system (not the one in AI lib and not also the A* standard method) to move towards the mouse avoiding obstacles

The example:
http://www.4shared.com/file/Tz4fvwXD/PointClick.html

in this example eve can move in 2 rooms: the entrance (the first place) and the hall (the second one)

You can’t go from the entrance to the hall till you turn on the light

Waiting your opinions and comments after trying it

Thanks in advance


#2

Why do you distribute the exe file? Are you using Windows-specific stuff? Many people can’t see that. :frowning:

PS And I’m very worried about egyptians. I wish you the best.


#3

yaio
Thank you for replying and for your feeling towards us
I don’t know how to make the game in exe but I used this method
http://www.panda3d.org/manual/index.php/Building_an_installer_using_packpanda

I tried to use packp3d.exe but it didn’t work

but exe will be found in the start menu


#4

Not everyone uses Windows, you know. Many people out here use Linux or Mac in which case they can’t run Windows executables and they certainly have no start menu.


#5

I got it to work under wine, but i cant seem to move into the hallway (after i turn the light on). Also when i click on the door i move to the corner

EDIT:

I am able to move to the hall only after i maximized the window, maybe its a wine issue.


#6

:confused: Sorry, I thought you were using packp3d/pdeploy, which is the current method. When I wrote I was implicitly saying to distribute the p3d file, but now I see that it isn’t possible with your approach.

Have you used the one in the daily build?


#7

I’m trying to use py2exe but I’m facing some problems…but does this work with other OS other the Windows

I should have made it in full screen…never mind

I can’t find it…the code browse in sourceforge has an error…or do I search in the wrong place?

Thanks you


#8

py2exe can only create .exe files, naturally. So no, it won’t work on non-Windows system.

You should really try to distribute a .p3d file. Let us know your problems with packp3d, perhaps we can help you with them.


#9

When Sourceforge isn’t under attack, you’ll find them here. When Sourceforge is under attack, click on the link contained inside that page.


#10

The whole point for him to use packp3d is to distribute his game, right? So he shouldn’t use the development version.


#11

I tried packp3d.exe before but it said that:
The Panda3D Runtime does not appear to be installed!
Although I downloaded the packp3d.p3d file also as it mentioned in a thread before
I don’t know if I should discuss the problem here or not

Thanks for reply


#12

The error appears to be that the Panda3D Runtime is not installed. The solution would be to install the Panda3D Runtime from the download page:
panda3d.org/download.php?runtime


#13

I had already downloaded the Panda3D Runtime before that but the same error appears, I also tried to uninstall then reinstall again and the problem still…I downloaded it in Panda3D-1.7.0 path


#14

Instead of running packp3d.exe, try running packp3d.p3d manually with panda3d.exe.


#15

It worked…but when I try to double click the p3d file it showed nothing…I tried to open it in command prompt

panda3d game.p3d

it showed:

DirectStart: Starting the game.
:display: loading display module: libpandagl.dll
:display: loading display module: libpandadx9.dll
:display: loading display module: libpandadx8.dll
:display: loading display module: libtinydisplay.dll
Know pipe types:
wglGraphicPipes
wdxGraphicsPipe9
wdxGraphicsPipe8
TinyWinGraphicsPipes
TinyOffscreenGraphicsPipe
<all display modules loaded.>

and nothing else…I searched on the web but find nothing useful

also the game airblade.p3d sometimes work and sometimes not
My panda3d Runtime is installed in C:\panda3d-1.7.0\panda3d path…what is the conflict?? wish to solve that


#16

Does it return to the prompt, or does it hang without opening a window?


#17

It hangs without opening a window


#18

I converted the file into p3d but it didn’t work with me
If someone could download it and see if it works with him

4shared.com/file/-yA1XR40/game.html

Thanks in advance


#19

It doesn’t work on my PC, but I receive a more informative error:

Garbage on XML stream!
Begin garbage:
��-��4��commandcmdinit
session_id6��-��4��commandcmdstart_instanc
End garbage.

But I don’t know what is this, I hope that other users will recognize it.


#20

Perhaps you accidentally installed the latest CVS version of the runtime? Or perhaps this .p3d file was accidentally built using packp3d_dev?

P3D files built with packp3d_dev require the CVS version of the runtime, while P3D files built with packp3d require the 1.0.0 runtime.
This annoyance will be resolved as soon as 1.7.1 is out.