Yet another chicken problem

My problem is this: When I try to export my desired model with chicken, nothing appears in pview or in-game. However if I export the model in .x and then convert it to .egg, everything is OK. I have also tried exporting it with eggX, but had the same problem.
I tried various things to make the model appear, such as remove armature animation (in case there was a problem with it), scale up/down the model etc. but the model still didn’t appear.
I exported various other models to check if there was a problem with the exporter but they were perfectly exported. My problem applies to only a single model. I have kept past versions of it, thankfully, that export normaly.
Any idea of what is happening?

Have you made sure all objects are selected when exporting, meaning the armature AND the object itself?

And, you can check the .egg file manually, is there content in there?

Oh, by the way, maybe your faces are inside-out flipped. Try flipping the normals.

The file has content in it.
I flipped the normals and had the same result.
I had everything selected but had the same result.
However, after checking the file I may have found 2 possible causes. 1, the model is too small (unlikely) and 2, it is transparent. I say that because the vertices’ RGBA values are all 0.0. Note that I have no idea of how .egg files work so I may be wrong.

Can you maybe put the EGG file online somewhere so we can take a look at it?

Sorry for taking me so long to reply (12+ hours) but nobody can stay online forever, can they?
The egg file is here -> I have met many rapidshare-haters, so if you’re one of them please skip the complaining and argueing part.
I can provide you with the .blend file as well, if needed.

I wont complain about RapidShare, but could you host it perhaps on a free file-host? I cant download on this one, I have to pay for that.

W…what? Rapidshare IS free. Just click “free” in the column where Select your download is writen (the choices are premium and free).
But in case rapidshare hates you (not unlikely) I have uploaded the file in a different host as you requested. The file is here

I think I found it:

      <RGBA> {

        0.0 0.0 0.0 0.0


That is the problem I think. The Alpha value is 0 for each vertex, that means they are all transparent. You have to give them a different color in your 3D editor.

FIXED :smiley: . I solved the problem in a rather crazy way (after all, I am crazy). I searched for all occurences of “0.0 0.0 0.0 0.0” and replaced them with “0.0 0.0 0.0 1.0” and everything works fine. Thanks for your help. I usually feed the ones who help me, so here, take a cookie: