Yet Another Blender Egg Exporter (YABEE)

yabee
blender

#361

I finally seem to have texture exporting working. I was not using UV coord’s which based on the excerpt from the latest Yabee makes sense. (There is a conditional in the collecting section that checks for UV coord’s)
Anyway, maybe there is another way, or maybe this is the “partial” bit implemented. I thought I’d post and try to save some other blender -> Panda folks some time.


#362

Ninth, I wanted to talk to you about (not) using custom object properties for ObjectType, Collide, Tags, all that. I still see a limitation using the built-in blender interfaces (game logic or object custom prop). The “name” field has no place to go in these interfaces. (unless you use the assumed tag in BG).
There are times when the name is nice to have (nodepath.find(‘name’), or say event collision handler throwing that name). Anyway, I think I have enough blender API mojo and a small enough understanding of the EGG format in these areas I would be able to create an add in panel that would let us fully define objects per the EGG syntax.
Let me know what you think.

S~


#363

I apologize for the silence again )

supus71
Some time ago, I offered to make a separate panel with specific properties, but people thought it was unnecessary. However, I did not abandoned the idea. May be to make the panel as the optional element? I would be glad if you can help me with this work.

preusser
Seems that I should to recheck all of my texture/material code )
As for procedural rigging: how important is it?


#364

@ninth: it’s not really procedurally generated, but a model I imported with another importer and exported as egg with YABEE. That’s how it assigns the Armature in its code.

My point is there seem to be multiple ways of assigning Armatures and YABEE only recognizes one. So if you have not created the model in Blender, but imported it with some importer, you might not be able to export it properly with YABEE. And maybe with GUI too.


#365

Hello!
Could you please tell more about animation exporting. What are these names in export window? If I have 5 animations in blender file, how would I specify which to export? Do those names have something in common with the animation names?
Maybe you know something about exporting baked animaiton in blender 2.6?
Currently if I export some simple animation everything is OK. But if I bake animaiton (to apply IK) I get a mess in panda window.

Thanks a lot!


#366

I have this model that I am attempting to export with a simple key frame for a standing animation. Exporting this model constantly gives me the error:

KeyError: ‘Torso’
location::-1

I have tried multiple times with several settings, but so far I get the same error. Every time it fails, a new scene is added. A screenshot showing a more detailed response is shown below. Exporting the model by itself seems to work just fine.

I really appreciate any help.


#367

Hello this a such a thin that i have never here before and is very interesting and how is going to work out.


#368

Sorry for the late reply guys :astonished: but I’m still having troubles adding collision.
Thought I’d just ask again lol.
I’m pretty new to Yabee and blender, I know most of the basics, and all that.
Seems I cannot use my egg terrain model because the collision isn’t set up.
Not sure how to edit the collision info, or even how to have it automatically set up my collision.

I tried reading through all the comments on this post about an auto one,
But seems I cannot find the actual code.

Thanks,
Luna


#369

Ninth, could this added to the Yabee readme or to your first post in this thread? It’ll help newbies like myself working out how to install it :slight_smile:


#370

2 more bugs:

first one, sometimes the UV coordinates of signle quad are flipped over both axis. i am not sure what causes this, converting the quad in question into tris fixes this.

the other, more severe one: all numbers are only saved up to 3 digits after the decimal point. that’s just not enough. especially if your model is of small scale.
i ran into this with a fullscreen quad on a 1080p monitor, the quad ranged from -.5 to .5 blending between 2 theoretically exact images caused a very visible jump of about 2 pixels. definetly needs more accuracy


#371

This may be related to the previous post…

I’ve got a blend file and a texture that looks fine when I render it (f12) in blender, but when I export it via yabee and then use the model in panda the uv mapping seems all over the place.

The .blend and associated generated .egg file are in this google drive directory.


#372

Hi to all
For a while I was busy and could not devote time to Panda ( Now I’ve got a bit of free time, and I hope I can glance at YABEE again.
I still hope… )


#373

Great news ninth! I’m very happy you’re still developing the exporter.


#374

Small update.
YABEE r12.1 (should work on Blender 2.63 - 2.65)
In this version I tryed to fix multiple bugs in objects naming, which in fact made r12.0 broken and useless.


#375

Hello ninth!
Just checked last version r12.1 on Blender 2.65x64. Looks like sometimes names with spaces are not converted to correct panda names. Group names are enclosed with “”, but vertex pool name is not - and gives errors like this on pview:

Error in yamaha-yafray1.egg at line 1288834, column 25:
    <VertexPool> Back rim {
                        ^
parse error

Thanks


#376

Thanks for report

Also i have a question - has anyone had problems with the UV coordinates - in .egg different from .blend?

EDIT: Ah, sorry, seems this topic [When export egg file for blender, uv is error.) has the requested issue.


#377

Hello Thomas ,

A quick fix for your second problem :smiley:

Open up the YABEE script in your code editor and you will find a constant declaration …

#: number of sign after point
FLOATING_POINT_ACCURACY = 3

Simply change this constant to whatever number you wish :smiley:


#378

It’s an outdated parameter, which can work only if you run script directly from editor.
For the standart method through menu you should edit init.py

        egg_writer.write_out(self.filepath, 
                            sett.opt_anim_list.get_anim_dict(),
                            sett.opt_export_uv_as_texture, 
                            sett.opt_separate_anim_files, 
                            sett.opt_anim_only,
                            sett.opt_copy_tex_files, 
                            sett.opt_tex_path, 
                            3,
                            sett.opt_tbs_proc,
                            sett.opt_tex_proc,
                            sett.get_bake_dict(),
                            sett.opt_merge_actor,
                            sett.opt_apply_modifiers,
                            sett.opt_pview)

In r12.1 I changed accuracy from 3 to 6.


#379

YABEE R12.2

Changed UV exporting
Removed internal TBS calculation due to unnecessary


#380

What? Why?
It’s very possible the modeller doesn’t have Panda3D installed on his PC.