XO Ubuntu Panda3d and glx [solved]

Having installed Ubuntu on OLPC’s XO, and eclipse+Pydev, and Blender -which all work, I’m just missing Panda3d to achieve bliss, hummm, achieve a portable and complete teaching tool…

But naturally, the XO does not have 3D hardware, so this will work (even if slowly naturally) if ican still mke use of glx for software rendering.

Contratry to what I<ve found on the web, there is no framebuffer-mode to change in the Config.prc file…

and for now, even after commenting the framebuffer-harware line, I’m still getting the usual error : “… if I eally want to…”

So yes, I do, the question is how ?

Thanks in advance!

The framebuffer-mode variable has been replaced with two variables:

framebuffer-hardware (true or false)
framebuffer-software (true or false)

If you want to allow either one, set both to true.

Thank you for a very prompt reply, Josh.

It worked just fine -and slow but that’s OK, the XO not being my main computer :wink:

It’s actually quite great!

Thanks again!