World of botS - the Unstable

Intro video:
get it from

My second game: World of bots - the unstable
Myopia is not dead, just on hold for a while.

It’s a multiplayer space game, where artificial spaceships fly around. Its focused around time efficiency, user value, cooperation, competition through tactical and strategical game play.
The user can craft tiny ships that he can setup as he pleases with various modules. The ships cant be controlled but they must be taught to explore, build, repair, attack and communicate with other ships. This is done through a simplified drag and drop scripting logic. The use can observe then how the bots are doing but can happily close the client and review the action later through logs as the bots remain in the space and will not disappear if client is closed.

The user can also add a system to the global universe(current restriction is the ports must be open), you can consider it as a Homesystem yet any bot can come conquer it. Every user hosted system will have a stability rating(the longer its kept online the more stable it will be considered), bots can be tought to avoid very unstable systems as the bots are destroyed if the system they are in collapses.

The goal is to control as much space as possible and make your bots survive.
Organizing in guilds can give you a huge advantage if used well with the broadcasting and timer system by ordering focused events at specific time moments at specific locations(at 2:00 AM all bots with guns jump to location(1:1) and shoot at sight, or all bots back to base to defend)

Gfx pimpup

Game package:
A closed alpha p3d. Will put it here as soon as its stable enough.



Looks interesting! Cant wait until you release it here, I want to try it out.

This looks promising. I like logic-based games :slight_smile:

Alpha ver 1
get it from

Redesigned ui a little
Added the manual(with brief descriptions for now)
Added an looping ambient sound.
Added stability(a little)

Try it.
Any feedback is welcome

Looks like some billboard textures could use some work. You can clearly notice that it’s a billboard.
Anyway, how did you do the anmated stars if it’s not a secret? :slight_smile:

For now my goal is not to strike with stunning graphics, simply dont have time for it, but surely hope to pimp the look at some point.
All the star like objects i made instanced billboarding and rotating plane with a single texture. They used to be 3d objects but while tracking some performance issues i replaced them, havent changed them back yet.

It looks cool.
I started it and got it working, but it crashed a few times.

What is cool:
-GUI layout
-zoom animations
-airship animations (flying around the stars) and the beams

What i think could be better:
-it’s hard to grasp what the whole thing is about
-the window was higher than my screen. therefor i couldn’t see the whole screen
-i can’t hear any sound
-the bot script editor seems undocumented and it’s pretty unintuitive
-you can’t clear single blocks from the script editor
-it’s unclear what modules are for
-an overview of your ships/bots would be nice
-the blinking stars are disturbing (how about making them blink slower?)

Thank you for the feedback.

A new build has been uploaded:

  • A more detailed manual
  • Changed the default window size
  • Added the sound(forgot to rference the openal lib :stuck_out_tongue:)
  • A few tooltips(right click to clear logic blocks)
  • Made the stars stop blinking(Its not actually blinking its texture flickering, cant really affect it but will see).
  • Removed and evil bug that made crashes(tooltips related)

A new build has been uploaded:

  • A even more detailed manual :stuck_out_tongue_winking_eye:
  • Made the systems able to freeze and reconnect to the main server if the main server goes down.
  • Fixed a roaming through systems error
  • Fixed an attacking issue
  • Added full screen
  • Added many ways of going into systems and sectors and exiting.
  1. Double click system or sector to enter, click the spc button on topr right to exit system or sector.
  2. Single click system or sector and press spacebar to enter. Click on empty space to clear selection and press spacebar to exit.
  3. Single click system or sector and do a fast wheel_up to enter, do a fast wheel_down to exit.

Cool, when I get time this weekend I’ll be sure to check it out.

made a new intro video. 1 min 47 sec.
I hope it gives a better overview about the game.

All the suggestions are welcome.


This game looks very intriguing! I really wanted to play it, but, when i got in the game i found i couldn’t zoom into sectors. I tried:

  • single-click space
  • double-click
  • single-click enter
  • single-click mousewheel-in

But nothing working. I can zoom out like a boss, but i cant get into sectors.

It’s such a shame, it has a ton of promise, but this bug is thoroughly keeping me from enjoying it.

Very intresting bug no one else has reported it and people are already building bots into the space.

Well i relly hope you are trying to zoom into energy objects as they might look a bit like sectors.

Below are 3 screenshot of the universe view, system view and sector view. Pleas tell me witch of these views you cant get or cant see in game, thank you.

Yeah, im definitely in the system view trying to go into a sector (As the entities have sector numbers bill-boarded on them, and the same info read-out). I really dont understand how im getting this bug, as i know the game is receiving the spacebar input.

I re-installed the runtime, and got your updated wob.p3d (Thanks for the window option) But im still not able to zoom into sector view.

It appears that none of the sectors have any energy left, could that be a conditional to entering the sector? Or could it be evidence of a corruption?

Ok i was able to get same error twice, yet it happens super rarely for me and i dont know yet why.
Is seems like the system kicks you/me(not sure thou why), for me exiting and entering the system allowed me to enter sectors.

You dont really need to reinstall the pandaruntime, its more likely mycode that is bugged :wink:

Uploaded a new client build, so atleast now it shows a dialog that tells about the kick.

Cheers and thank you

I got the new wob.p3d, but when i try to zoom into sectors i dont get an error at all. I tried doing what you did and zooming out to the Galaxy view and then trying again but that didnt change anything.

By re-installing the runtime, i meant getting it in the first place :).

This is such a weird bug, i haven’t seen anything like it before in any of my projects. Could it have something to do with the server-end?