Windows install: NVIDIA GeForce texture issues

Greetings all!

I’ve just begun playing with Panda 3D 1.0.4 on my Dell under Windows XP with a GeForce4 MX 420 graphics card. The install went off without a hitch, but when I run the “greeting card” demo or the demos in Lesson 1 of the Basic Tutorials, nothing is textured (and the text in tutorial 1.2 shows up as boxes instead of text–also a texture issue, I would guess). Furthermore, errors are reported on the output console: for example, tutorial 1.2 gives me the following errors (note: the global clock’s real time error always shows up, so I don’t think it’s related):

:display:windisplay(warning): SetForegroundWindow() failed!
:express(warning): Adjusting global clock’s real time by -0.446167 seconds.
:display:gsg:glgsg(error): at 3420 of d:\temp\mkpr\panda3d-1.0.4\panda\src\glstu
ff\glGraphicsStateGuardian_src.cxx: invalid operation

I discovered through trial-and-error that if I go to the Display control panel, in the Settings tab, select the Advanced button, go to the Troubleshoot tab there, and dial the “Hardware Acceleration” slider to the second notch from the left, text shows up correctly (but the performance speed of the demo has suffered considerably). The second notch from the left has the following description attached to it:

“Disable all but basic accelerations. Use this setting to correct more severe problems.”

Setting the slider to this option makes the above errors go away and causes the proper textures to appear in the world, but things are much slower in the greeting card.

Am I tripping over a known issue with NVIDIA graphics cards? Is there anything I can do to side-step this problem without sacrificing so much performance?

Thanks for your help!

Yes, this is a known bug with a particular version of the NVidia driver, released last year. It simply won’t load textures in hardware-accelerated OpenGL mode.

The only solution is to download and install a more recent version of the driver. You can do this from


That fixed the problem; everything is now smooth, fast, and colorful. Thank you for the help!