WinCVS & Panda


after I finally managed to build a debug version of Panda (and after I finally got my internet back…), I would like to check out the Panda Source code directly from CVS.

The manual is not very clear about how to do this.

I found this

Source Code Repository
To get access to the latest bleeding-edge development version of Panda3D, you can check it out from the CVS repository using the command:
cvs -d co panda3d

in the manual

and here saying 2 different things.

Where the second seems to match the descritpion on sourceforge itself

I am new to CVS and havent used it before, how do I set this up ?

I have installed WinCVS (Build 4).
I first created a new folder c:\Panda3D this is where I want the source code to be.

Then I right clicked on the c:\Panda3D folder in CVS and selected “checkout module”

there I set it up as in the picture

I used " cvs -d co panda3d

but the checkout fails with :

cvs checkout -P – “cvs -d co panda3…” (in directory C:\Panda3D)
cvs checkout: No CVSROOT specified! Please use the `-d’ option
cvs [checkout aborted]: or set the CVSROOT environment variable.

***** CVS exited normally with code 1 *****

what am I doing wrong ?
I have tried to use the “2 lines” from the other websites but they also fail.

I don’t have direct experience with WinCVS, but I can see what you’re doing wrong. The command “cvs -d co panda3d” refers to the command you will type if you are using a command-line CVS program, not WinCVS. In this command, the CVSROOT is the string following -d, and the module path and name is the string following co.

So you should put "" in the CVSROOT blank, and “panda3d” in the module path name name blank.

Note that this is all standard CVS operations, and not specific to Panda3D; and there are pretty good CVS references on SourceForge.


ok using the CVS string as you said :

I got 1 step further :slight_smile:

I can “see” the panda repository (see picture)

but I get

cvs -d " " checkout -P – panda3d (in directory C:\Panda3D)
cvs [checkout aborted]: authorization failed: server rejected access to /cvsroot/panda3d for user pserver

***** CVS exited normally with code 1 *****

as far as I know there should be no password for anonymous read only check outs ?

I am sooooo close :stuck_out_tongue:

Remove the first “:pserver”.

that was a mistake in the attempt when i tried taking the screenshot

cvs -d " " login
Logging in to
cvs [login aborted]: authorization failed: server rejected access to /cvsroot/panda3d for user anonymous

***** CVS exited normally with code 1 *****

got it to work (FINALLY! )

I had to login first

I used
Admin / Command Line

cvs login

then rightclick on my c:\Panda3D folder (in WinCVS)
and check out module.

there I entered “panda3d” as module name and

Local Folder to checkout : c:\Panda3D