why can't see some faces in front of them but in back of ?

some Blender models made by me or downloaded seems no problem,when export them to eggs,and load in panda3d,the matter I said occurs,but when rotate the model some degrees,those faces appear and some other faces disappear,
Another question is, a egg export from blender looks semi-transparent in panda3d, but the .x file made by egg2x with that egg looks ok in M$'s MeshViewer :open_mouth:

You question is really not very clear, but I’ll take some guesses at what you mean.

Backface culling is an important optimization. There’s no point in rendering a face that would be occluded anyway. However, the only way to tell which side of a face is the front is by which way the normal is pointing. Recalculate normals outside and export again or just turn off backface culling for that model and see if it helps.

If the problem is backface culling it should only apply to an improperly constructed model. Try rendering one of the models that came with panda and see if it works better.

The near clipping plane is another important optimization. Nothing past the near clipping plane gets rendered. Try pulling your camera back, pushing the model back, or changing the near-clipping plane on your camera. This applies to even properly constructed models.

thank you ,Cyan;I mean, some egg models export from Blender(using psiberpunk 's CHICKEN exporter)has problem to view in Panda3d, for some polygon,I can see them only in one side , get me now…? the semi-transparent egg model is another strange thing; thanks for your helping on graphics;

See the manual page: http://panda3d.org/manual/index.php/Backface_Culling_and_Frontface_Culling


I think I know what your problem might be. Blender always shows faces as double sided in every mode except UV/Face select mode (press F when in object mode), or in the game engine view (press P to see that). So, faces that you might see correctly in Blender’s object and edit modes might actually be facing the wrong way. I only export faces as double-sided faces when they’re flagged as such (and look as such) in the UV/Face select mode, which is something the X exporter might do differently and why it might look correctly when using that and not Chicken.

Another way to tell if this is your problem is to turn on the drawing of face normals. If the face normal is pointing inward instead of outward, the face will look wrong when exported. You can do this by going into Edit Mode and depressing the Draw Normals button in the Mesh Tools 1 panel.

Thanks to every one;Thank Cyan for your helping on graphics;Thank David for the important & useful link;Thank psiberpunk for your helping on Blender;I love you!(,I know I’m not on Grammy 's stage and I’m not a gay) The problem now can be solved by simply adding “xxx.setAttrib(CullFaceAttrib.make(CullFaceAttrib.MCullNone))” or do "Flip Normal"in Blender