I am running my program on a couple different computers. The 2 machines in question are my main desktop PC with nvidia 6800 graphics card, and an old HP laptop with onboard graphics.

The laptop achieves a framerate of about 128 - 150 fps as reported by globalClock.getAverageFrameRate()

The desktop, on the other hand, hits almost exactly 60 fps (59.96 - 60.04). I read a thread on the forum regarding vsync, but I cannot figure out what I need to do. I added:

vsync #f

to config.prc, but to no avail.

Any other thoughts?


Hmmm. This might be overridden by the driver. I have seen a case of drivers giving you the ability to explicit set vsync regardless of program setting.

If that is the case, I am not sure what you can do.

interesting. I went into the NVidia control panel, and the vertical sync was set to ‘Use 3d application settings’. I changed it to ‘Force Off’ and mow I am getting 160fps.

Good to know. Tagging this post for anyone else that is searching for the same issue…

NVidia vertical sync GeForce 6800

For the record, the correct Panda3D config variable for this, which would be consulted if you left the driver setting at “Use 3d application settings”, is “sync-video #f”.