Visual Studio 2017: Intellisense for makepanda is not working

Hello. I am using Visual Studio 2017.
Problem: when I press Ctrl+Space, it says: “Intellisense: no additional information available”.
I can’t get code auto-completion. I tried deleting .vs folder and reindexing, but this didn’t help.
Did anyone have this problem?

Please help. Everytime I want to change / look up something in Panda source code and open makepanda.sln solution, VS 2017 turns into a notepad.exe. VS 2019 seems to behave the same.

makepanda.sln isn’t an actual VS solution, just something that invokes makepanda under the hood. We should remove it.

I know nothing about IntelliSense—it’s always the first thing I turn off after I install VS—but if you want a working VS solution, you should try building Panda from the CMake branch.

Yes, I read that makepanda will be deleted, but did you mean the whole build system or just a solution?

It’s an interesting approach. It shouldn’t work out of the box for NMAKE projects anyway.
https://docs.microsoft.com/visualstudio/ide/visual-cpp-intellisense-configuration?view=vs-2019

Thanks, I’ll try that.

EDIT: Yes, that seems to solve my problem. Thanks again.

OK there seems to be a problem, when I build a sample program with a custom Panda3D build, it searches for the entry point in libpanda.dll, but the cmake branch builds every library without lib prefix.

How can I configure this, can you please help?

The developer @CFSworks helped me with the solution here. Set CMake option to CMAKE_SHARED_LIBRARY_PREFIX=lib to make it compatible with older makepanda headers and libraries.