Verify installation on Uuntu 12.04 LTS (Precise)

I installed libcv2.1_2.1.0-7build1_amd64.deb and libhighgui2.1_2.1.0-7build1_amd64.deb downloaded from the oneric package site, then panda3d1.8_1.8.0~oneiric_amd64.deb from this site. Installation of all three packages was successful.

When I try to run the samples - I tried the Asteroids and Teapot samples - I just get a black screen. In the terminal I see the following messages:

DirectStart: Starting the game.
Known pipe types:
(all display modules loaded.)

No error messages as far as I can tell.

I tried changing the load-display parameter in /etc/Config.prc from pandagl to pandagles, which provoked error messages which were repeated until I killed the process.

:display:gsg:glesgsg(error): FRAMEBUFFER_INCOMPLETE_ATTACHMENT_EXT for hello
:display:egldisplay(error): BadMatch (invalid parameter attributes)
:display:gsg:glesgsg(error): EXT_framebuffer_object reports non-framebuffer-completeness:

I also tried the tutorial from the manual, I see the (correct?) background, but no rocks or bamboo, and no panda.

Here’s whet I see:

This is one frame, the camera is turning.

It looks like the modelpath is correct, renaming environment.egg.pz caused the script to fail with a ‘file not found’ error.

I have an NVidia GeForce 9800 GTX graphics card.

Any ideas about what I have missed?

You shouldn’t use Panda for Oneiric. You can use this and if you need librocket, refer to my post here: [SOLVED] Can I install Runtime insert SDK ?

Make sure to completely remove the packages from Oneiric.

It sounds more like a graphics card problem, really. Can you run other OpenGL applications, such as glxgears? Which drivers do you have installed, nouveau or the official nvidia drivers?

Thanks for your help.

Glxgears works fine.
As far as I know, I have the Nvidia drivers provided by the manufacturer. My system complained bitterly about them being propriertary when I installed them.

I just deinstalled and reinstalled the JörnS version.

This seems to be working correctly, Asteroids, Teapots and the Panda show as expected.

Vielen Dank

Next dumb question: what’s the difference?

At the risk of taxing your patience:

All I have to do now is fix the installation on my Raspberry Pi (Raspbian OS).
I insalled the Hardfloat version from

There I get a black window on all three tests: Asteroids, teapots and the tutorial.

Raspi is a 512mb model B. I still get the black screen after setting the GPU memory to 192 MB.

Any ideas here?

Gern geschehen! :slight_smile:

Way back to english, as it’s the forum language. Unfortunately, I don’t know anything about the Raspi.

The version compiled for Oneiric depends on older software, which doesn’t integrates well with Precise and newer drivers. In some cases packages from other versions work well, for example you can use the package for Precise in Quantal and vice-versa.

1.8.1 will be released in a few hours, which will come with precise and quantal builds.

Reinier, you are awesome! Many thanks!

EDIT: Did a quick test, seems to work fine. But why is there a build for Oneiric (which hasn’t updates any longer) but no build for Raring (which is final in a few days)? :slight_smile:

Because I already had oneiric set up, and because raring hasn’t been released yet.

Many thanks for the info.

I think I’ll stick with what I’ve got, as it seems to be working.
One of the challenges with the LTS is the fact they are a LTS release, and don’t brought up to date as time passes. Installing newer software can become a bit tricky, especially when the release ages.

Yes, know what u mean. Will be interesting, as Precise has 4 more years support. 2016 there are 3 LTS versions of Ubuntu at the same time, Precise + 14.04 + 16.04. Heavy for small teams.

to me it soudns like a graphics card problem