v1.5.1 and Normal maps

After upgrading to ver 1.5.1 I had three problems with my scripts that were never an issue before:

  1. the texture stage order is a little different- this wasn’t a big problem, I just reordered the texture stage- looking through things it looks like the change in v1.5.1 may have been a bug fix- anyway it required a change to my code. Not a big deal, it’s fixed now.

  2. The following code worked great before- now it doesn’t.

myNormalMapTex = loader.loadTexture('models/craternormal.png') 
self.me.setNormalMap(myNormalMapTex, '', 0)

I don’t know how to fix it either. Anyone have any ideas?

  1. Also for some reason I can’t get antialiasing to work as it did in previous versions-
loadPrcFileData("", "framebuffer-multisample 1")

What version were you using before?

I was using v1.5.0.

I can’t remember when the last time was that I used the specific script on normal maps cited here- I know I used it and it worked fine in v1.4.1

I would just switch the script to using the automatic shader generator but the program makes extensive use of cubemaps as well and they simply don’t work with the shader generator yet.

so, AA on Windows is finally broken too, as on Linux.

yeah, AA is broken- it’s pretty sad because it really makes a big difference.

I just tried 1.5.1, AA completely works GREAT !!

what code are you using to get the AA?

The same lines. You tried that on Windows, right ?
What is the return value of this :

print base.win.getFbProperties().getMultisamples()

Panda 1.5.2 windows

this line print base.win.getFbProperties().getMultisamples()

returns 0…

is that normal?

EDIT:Nervermind,i got it working

i wasnt using loadPrcFileData("", “framebuffer-multisample 1”) before directstart