/usr/bin/panda3d executable missing in Ubuntu?

I’m using the default installation of Panda3D that comes with Ubuntu. Python scripts that invoke Panda3D can be run successfully with the command “python script.py”. But I cannot run .p3d files as described in the documentation, because the binary “panda3d” is missing.

“panda3d” is not in the list of files installed by the Ubuntu package, so I know it’s not in a non-standard directory. And running a .p3d file directly as an executable doesn’t work, because the system simply looks at the first line of the .p3d file, which directs it to “/usr/bin/panda3d”. So either the executable has been given a different name, or something more complicated is going on that I don’t understand.

Sorry if this has been solved – I searched the forums and FAQ and couldn’t find an answer.

Welcome to the forums!

You need to install the Panda3D runtime to get the ‘panda3d’ executable.

Worked great. Thanks very much. The repository didn’t have a version for my distribution, but I downloaded and installed the .deb archive without a hitch.