Unable to import VRoid model to Panda3D

Hello everyone.

As the title says, I cannot import a VRoid model to Panda3D. So far, Panda3D was able to load the model on the Panda viewer, but trying to implement it in code comes out with this error:

AssertionError: inserted at line 145 of c:\buildslave\sdk-windows-amd64\build\panda\src\gobj\sliderTable.cxx

The code itself is nothing usual. It only just scripted to import the model.

from direct.showbase.ShowBase import ShowBase

class Game(ShowBase):
    def __init__(self):

        self.object = loader.loadModel("models/testModel")

game = Game()

What type of model is it? What extension does it have? Which version of Panda3D do you have?

It’s a character model with bones (animation rigs) with it. I am using VRoid Studio 0.11.3, Blender 2.91.0 with kergalym’s YABEE 15.5 and VRM_IMPORTER 0.103.0, and Panda3D SDK 1.10.7.

Here is the link for Panda3D’s model with its textures, alongside with the .blend, and .vrm file.

Strangely enough, before making this comment, it worked (and still is) before with a different model. Sadly, I did not know what I did to have it work.

I got the solution for it.

For whatever reason, the program needs to crash at least once for the model to successfully load again.

I don’t think that’s the solution.

That is understandable. In that case, I tried it again with another VRoid Studio’s model.

I went through the same process on setting the texture’s ready for Panda3D. After I export it, I made a different .py program that is separated from Panda3D’s models folder, and my project’s folder.

Using the same technique that I described earlier, I can still confirm that it works.