Ubuntu Breezy - Blank Screen

I have recently installed deb package of version 1.1.0 on ubuntu breezy. Installation process finished successfullly but if I try to run examples I see only a blank grey screen without errors.

What should I do? Are there any dependicy package?

There might be a problem with OpenGL installed on your system. Does it work in software mode, for instance if you edit Config.prc and change

framebuffer-mode rgba double-buffer depth hardware


framebuffer-mode rgba double-buffer depth software

If this works, you can then decide whether you want to continue to run in software mode, which will work, but will be fairly slow on large scenes, or whether you want to figure out what’s wrong with OpenGL on your system and install it properly.

What are the startup diagnostics when you run one of the examples? It might shed some insight on the problem.


What results do you get when running “glxgears”? What is “glxinfo” telling you? Does it contain the following line?

If not, you need to set up your OpenGL first. However, with Debian testing/unstable I am having the same problem too… black screen, nearly no geometry and NO textures at all… - but that seems to be a different problem, that is not Panda3D related and thus not discussed here…)

Uh, and I HIGHLY suggest to try removing 1.1 and trying 1.0.5 as well… in case that ain’t working too, you might be REALLY in trouble…
(you can test the networking tutorial from 1.0.5 (not sure if its still in 1.1), tell us if you can see the Chat window)

Regards, Bigfoot29

Can somebody help me I have this problem too
This is the output

Known pipe types:
(1 aux display modules not yet loaded.)
:display:glxdisplay(error): Using GL renderer Mesa DRI Intel(R) 852GM/855GM 20050225 x86/MMX/SSE2; it is probably hardware-accelerated.
:display:glxdisplay(error): To allow use of this display add FM_hardware to your frame buffer mode.

I run glxgears and it works. glxinfo tells me Direct rendering: Yes
I’ve changed the config file to

load-display pandagl
aux-display pandagl

Any solutions?

Since you have a hardware-accelerated GL, you should make sure your framebuffer-mode variable includes the keyword “hardware”, not “software”. This is the opposite of the advice we gave LeoKhan. The error message you are describing is telling you that Panda is complaining that you have requested a “software” framebuffer, but you have hardware acceleration.


Ok i’ve now chaged the config files back.
But when i run pview the window opens black changes to gray and does nothing
The output:

Known pipe types:
(all display modules loaded.)
Loading garden.egg
897 frames in 12.4991 seconds.
71.7654 fps average (13.9343ms)

Any sollutions?

Do you see a blue triangle when you run pview by itself? Try putting the line:

show-frame-rate-meter 1

in your c:\Panda*\etc\Config.prc file. Do you see the frame rate text in the corner? In pview, when you press the comma key repeatedly, does the gray background cycle through different colors like white and black?


I see no triangle and no frame rate meter if i edit the config file
When i run pview the window popups with black and changes after ~1 sec to gray
Thanks for help Martin

Hmm. What sort of output are you getting in the window you start pview from?

Do other OpenGL applications appear to work?


This is the output of pview:

Known pipe types:
(all display modules loaded.)
Loading panda.egg
3417 frames in 36.4098 seconds.
93.8484 fps average (10.6555ms)

if i press the comma key the color of the window changes

As for an answer of the other GL programs do work:

Stated above, they do :slight_smile:
So it seems to be indeed a Panda3D-Centric problem…

However, I am still wondering if the networking tut of 1.0.5 does show up as it should. In case it does, copy its content over to 1.1 and change the code so that you see the background image (or write a small prog that loads the networking background image to the screen (see the main() section in the server/client example I provided. There the background image and the appropriate command are also in…)

Regards, Bigfoot29

I admit to being baffled. The fact that you are seeing the background color change indicates that (a) Panda is rendering to the window, and (b) it is responding to keyboard events. But you’re not seeing any triangles, which is really strange.

Here’s a heavy debug hammer. Edit your Config.prc, and add the lines:

notify-level-display spam
notify-level-glgsg spam

Then try running pview again, dumping the output to a file. If you use bash, the syntax is:

pview 2>t.txt

Shut it down within a second or two after you see the gray screen, since it will just be accumulating reams of spammage into the log file. Then email the log file to me (click on the button below for my email address); maybe this will help me diagnose the problem.


OK, I have received the log file, and it tells me that Panda is indeed issuing vertex commands to your driver. If you’re not seeing anything, it strongly suggests a driver bug.

Try putting the following lines in your Config.prc:

vertex-buffers 0
vertex-arrays 0
display-lists 0
connect-triangle-strips 0

Try all of them at once, and then try them one at a time. Each of these turns off a different advanced feature of OpenGL, any one of which might be triggering a bug on your graphics driver. I’d love to know which of these, if any, makes it work again.


Hi David thanks for your help.
I’ve tryed all options but nothing happens i always got a gray window

OK, the next thing I can suggest is maybe there is some library incompatibility with whatever OpenGL library you have installed, and the one we have compiled Panda with. This isn’t supposed to be a problem–OpenGL is supposed to be runtime compatible across different versions–but who knows, anything is possible at this point.

Is it possible for you to uninstall your binary distribution, then get the sources and build Panda from source?


Yeah its possible i’ll try to compile it
Thanks for help

I also have a Intel 852GM/855GM video chip and am experiencing the same problems described in this thread: hardware accelerated OpenGL working fine but panda3d window is always grey on startup. I have found that resizing the window fixes this. I would be interested to know if anyone comes up with a ‘less dodgy’ fix.

This probably isn’t very useful, but I am running Panda 1.1.0 on Ubuntu Breezy as well. When I first ran the demos I got only a blank screen for a long time. I ran them a few times, left them running and waited, eventually the demo popped up. I really don’t remember doing anything to fix it. After that it worked fine - I didn’t see the blank screen again.

What windowmanager do you use? or isn’t this nescessary? Im using IceWM but before i had GNOME where it didn’t work too

I am using GNOME (desktop environment) with metacity (window manager), but I don’t think it matters. It’s more likely a driver thing.