Ubuntu 12.10 - Can't install Panda3D

I thought the downloads included what was needed ? I get

dpkg -i panda3d1.8_1.8.1quantal_amd64.deb
(Reading database … 169445 files and directories currently installed.)
Preparing to replace panda3d1.8 1.8.1-1~oneiric3 (using panda3d1.8_1.8.1quantal_amd64.deb) …
Unpacking replacement panda3d1.8 …
running ldconfig
dpkg: dependency problems prevent configuration of panda3d1.8:
panda3d1.8 depends on libboost-python1.49.0 (>= 1.49.0-1); however:
Package libboost-python1.49.0 is not installed.

and about 20 more things that need to be done.

How do you install it on Ubuntu 12.10 ?

I have…
Kernel Linux 3.5.0-17-generic
Release 12.10 (quantal) 64-bit
GNOME 3.6.0

And nothing I do will remove the old Panda failures I tried
dpkg -r

But no luck… Then it said the “Package is of bad quality”

intian check results for /home/mark/Downloads/panda3d1.8_1.8.1~quantal_amd64.deb:
E: panda3d1.8: file-in-etc-not-marked-as-conffile etc/Confauto.prc
E: panda3d1.8: file-in-etc-not-marked-as-conffile etc/ld.so.conf.d/panda3d.conf



I got it, it worked the 4th time I tried to install it for some reason.

I’m new and in a big hurry, so I hope you will forgive me.


Just for the records: “dpkg -i” doesn’t pull in the dependencies. There are two propers ways. The geek console way:

dpkg -i panda3d1.8*.deb
apt-get -f install

Or you can install it with an appropiate GUI, for example the Ubuntu Software Center or GDebi. The Lubuntu Software Center can’t install local packages, I don’t know what Ubuntu Gnome ships. If you wan’t to upgrade your Ubuntu (12.10 is supported till April '14), you can find Panda3D build here.

Hi everyone,

I have a large class of game development students doing their yearly 3-week Panda project and, as usual, we’re struggling with the Maya pipeline. Most are on Windows, and I was able to build a 64-bit Panda installer for them with Maya support without too much trouble. But I’m really stuck on getting this for the ones who have OSX. Previously I’ve been able to get this to work for Maya 2011 and 2012 with a lot of workarounds and hacks, but those versions I made don’t seem to work anymore; and I don’t seem to be able to build a usable panda installer with maya support for any version any more.

Hi hassan123,

It might have been better for you to create your own thread for this matter. I can split it off if you wish.

Which Mac OS X version are your students using, and which version of Maya?