The list of known bugs in 1.6.0

F=Fixed U=Unfixed P=In progress
P Problem with WX+CommonFilters (forum)
U setParentWindow on OSX (forum) (lp)
U Max 2009 problem with UV’s (forum)

LP bugs

I don’t know if it counts as a bug, but the DirectX drivers don’t really work with the shader generator, and appear not to support depth textures.

Huh? That shouldn’t be, I’ll look into that.

I have just got a gf 9500GT. I also have the problem of depth texture problem.

Also the Normal Mapping demo crashes on this new card ! The old integrated graphics card can run well on the normal mapping demo.

I have the latest driver installed. OpenGL mode is running well. DirectX applications seem running well also with other applications, like OGRE.

Hmm, interesting. I’ll try the mentioned samples on my 8600 on windows.

Okay, both bugs aren’t actually bugs.

I’ve checked, and it’s Panda’s DX9 implementation that’s lacking support for depth buffers.

My GeForce 8600 card doesn’t crash, but does give me some very odd errors (also visual) that appear to be caused by some unimplemented stuff.

Unfortunately, DirectX in Panda seems to be in a pain of state - feel free to improve it, if you can. :slight_smile:

Is playback of movie files working in 1.6.0? I know ffmpeg isn’t working on OSX yet, but I haven’t tested 1.6.0 on Windows yet and I saw you mention somewhere something about MovieTexture being broken.

On OSX, you should still be able to play movies through OpenCV.
MovieTexture is indeed broken and it will be fixed in 1.6.1.


I seem to be having problems with the dae2egg converter, if you try to run, it just crashes.

I have tested on 2 systems both in Vista (with and without administrator rights / compatability mode) and XP SP3, both have the same behaviour of crashing and not converting the file.
I don’t actually have to specify the dae file for it to crash just running it crashes it whereas I assumed there would be a help message displayed like the other converters.

If I can provide any further testing let me know.

Thanks, Gachuk

Yes, on Windows, there are problems with the way the collada exporter is linked. I’ll make sure it gets fixed before 1.6.1.

On a sidenote: The OpenAL issues on Linux are fixed for 1.6.1 - I really hope we can get it as stable and fast as FMOD, so we can make it the default again.

Minor little note, and I’m not sure if this is a bug specific to this release seeing as its the first time I’ve ever used the particle panel, but when you try and add a texture for a sprite renderer it complains about there being no maps/lightbulb.rgb - doesn’t appear to exist in the panda directories. Easy enough to fix - I just copied one of the other .rgb files and renamed it, but might want to arrange for that file to exist, or at least make it so the particle panel doesn’t bug out because it doesn’t exist.

I’ve just added the file. I have no idea why it’s needed, but it at least won’t error now.

I’m not sure if this is a bug or a limitation, and sorry for not trying to figure this out myself.
How can I get ActorInterval from ivalMgr ?
It’s not even listed in ivalMgr.findIntervalsMatching(’*’).

Ah, since ActorInterval inherits from Interval and not from CInterval, you will find it on the task manager instead of on the interval manager. This little weirdness has been with us for a while, it’s been on my list of things to straighten out.


Of course it’s there. In fact, I already caught LerpFunc, but simply ignored the rest of python-based interval types.

A segfault in this code:

from direct.directbase import DirectStart


Any ideas what could be wrong?

I tracked this down to:, the simple PandaNode above, was being removed and deleted by the flatten operation. However, the base.mouse2cam node still had a (non-reference-counting) pointer to it, which was now invalid. When it tried to set the camera position next frame, boom.

I’ll “fix” this by making base.mouse2cam keep a reference-counting pointer to its node. Also, should probably be a ModelNode anyway, so it doesn’t get accidentally deleted by an overzealous flatten operation like this; I’ll make that change too.


Excellent, it works now. Thanks alot!

is there a way to get a version working in 1.6.0 ?