Texture on a .egg model

Hi, I have some issues with importing textured models (I’m a beginner on Panda3d).
I created a 3D terrain on L3DT and exported the Heightfield and Texture map on Blender, and then used Yabee to transform the file in .egg
The problem is, I can’t see the textures of my map in Panda, it is just white.
There are no error messages when I run the code.
I have no instructions about the texture in my code, but i think the texture is already integrated into the model (?)
(I still tried to add a line to integrate the texture directly on Panda, but it doesn’t work)

I used exactly this video to make the model in Blender:
https://www.youtube.com/watch?v=BXDSfrzR0zI

Thanks,

Paul

Only texture path is integrated in the .egg model. You can open .egg file with a text editor and see where is the <Texture> {} block poiting at. If I remember correctly, YABEE exports them in a tex folder.

P.S. this is for Blender 2.79, I don’t know Blender 2.8 workflow.

Thank you for your reply,

Effectively, I have this on one of the models i tested:

Texture {
"./tex/Heightfield_TX.jpg"
envtype { MODULATE }
minfilter { LINEAR_MIPMAP_LINEAR }
magfilter { LINEAR_MIPMAP_LINEAR }
wrap { REPEAT }

but with this map particularly, I can’t see anything on the Panda window, not even the model without texture

For the others, I can’t find a texture path. I tried also with the standard cube of Blender, and no way to find this line.
I’m on blender 2.79

Judging by the text you’ve posted, you don’t seem to have UV coordinates in the model file.

In fact, UV coordinates are stored in the vertices, not in the texture. You can create a simple cube or plane and place it on the forum completely. Then we can identify the problem.

Also, the absence of UV coordinates can also be a problem.

In the case of the eggs that lack a texture reference entirely, it may also be that the textures were applied in a manner that Blender displays but that YABEE doesn’t export.

Specifically, if I’m not much mistaken, YABEE only exports textures applied in the texture slots of materials. Textures applied simply in the UV-/Image- editor are not exported by YABEE.

I applied the texture to two different objects using two ways.
But there again no “texture path” when I open them with notepad and the object is still without textures on Panda.

I checked on the instructions for Yabee and it exports UV layers / Materials and textures (partially) so I’m a bit lost

planche.egg (4.4 KB)
cube.egg (401 Bytes)

I’m sorry I think my lack of knowledge on the subject is a big part of the problem, but thanks for your answers

Can you upload a Blender file instead?

Here it is:

planche.blend (504.2 KB)
cube.blend (474.0 KB)

I think you have to use Blender render. Then you need to assign a texture to a material. I am not sure if YABEE works with node-based Cycles renderer.

The files you provided do not contain any texture records. Note that textures are supported only through the Textures tab, as well as Materials. Nodes were not supported, of course, something may have changed since I used YABEE.

1 Like

I think that the Blender 2.8 fork of YABEE might export nodes–but indeed, I think that the base version of YABEE doesn’t.

Oh ok I started all over by changing the way to apply the texture on Blender and as you said it was the problem.
It worked for the small objects I took to test, but the last remaining problem for my map is this error:

Couldn’t allocate memory page of size 131072
Process finished with exit code -1073740791 (0xC0000409)

Is this problem linked to the computer performance ?
because the terrain is not gigantic and the texture is not of high quality

test.blend (497.7 KB)

You may not have enough RAM, I exported this model normally.

It’s weird, I still have 8 GB, it’s more than enough, isn’t it?

I think you should also provide a texture for your .blend file (it is not embeded in the blender file)

It seems that someone else had a similar problem, as seen in this thread.

In that case, it seems that the dev in question was building a 32-bit application and running it under Windows installation, and that Windows apparently imposes some limitations on the amount of memory given to a single 32-bit application. To quote:

(The dev did later note that the limit may be higher under Windows 7 Professional; I don’t know whether it varies further under other versions of Windows.)

Does this perhaps apply to your case? That is, is your application 32-bit, and are you working under Windows?

If so, the question then comes back to that of why your program is using up more than the limit…

Yes indeed i have python 3.8 (32 bit) under Windows 10

So it may be that your full 8GB isn’t available to any one app. (I imagine that it’s still useful by virtue of allowing two or more apps to access memory up to the per-app limit.)

What happens if you halve, or quarter, your terrain? Does it export successfully then?

It worked when I cut the ground in four but there is not much left …
and the file size only went from 170 to 130 MB (which may be already a lot for what it is)