Strange texture behaviour on 3d text [solved]

I created a directFrame with two onscreenText and reparent the frame to a point upper avatar’s head and applied billboard effect to it.
The result is good except that I’m having weired “shadow” arround my onscreenText.
You can see it in the image bellow:

This shadow only appears when the frame pass through a texture which is far away or when two textures are near each other.
It must be linked to the transparency of the frame and I don’t know what should I do to change the transparency mode of it…

Try setting a different transparency mode on your text, e.g. text.setTransparency(TransparencyAttrib.MBinary). This will avoid the shadowing effect, though your antialiased edges won’t look as nice.

If you have a high-end graphics card, you can also ask for TransparencyAttrib.MMultisample, which will preserve the antialiased edges if you also have “multisamples 4” or so in your Config.prc file. Not all cards support this, but if it doesn’t, it will fall back to MBinary anyway, so you might as well.


None of the transparency mode I tried did work!
I’ve tried MNone,MAlpha, MNotused, MMultisample, MMultisampleMask, MBinary and MDual. Is there other possibilities ?
I already faced a similar issue with one of my models where I had to manualy change the alpha mode in the egg but here there’s no such thing to do!

I agree that it’s not that important as the main game is working, it’s only a small aspect issue… But this kind of bug can ruin it!
So, David, should you have any other secret weapon in your hat, I’ll take it :slight_smile:

Try it with an override setting:

text.setTransparency(TransparencyAttrib.MBinary, 1)


It worked :slight_smile:
The edges are less sharp but I prefer this solution.
Here’s the result on a near tex (left) and far tex (right) :