Strange dependency problem on compiled deb in Debian Jessie

I compiled the panda3d git snapshot with:

python3 makepanda/ --everything --installer

and attempted to install the resulting deb:

dpkg -i panda3d1.9_1.9.0_amd64.deb 

but this fails with:

dpkg: dependency problems prevent configuration of panda3d1.9:
 panda3d1.9 depends on libc6-amd64 (>= 2.14).

dpkg: error processing package panda3d1.9 (--install):
 dependency problems - leaving unconfigured

However I do have libc6-amd64 installed:

$ dpkg -l | grep libc6-amd64
ii  libc6-amd64                           2.19-15                             i386         GNU C Library: 64bit Shared libraries for AMD64

Anybody know what’s going on here?

I seem to have found a workaround - use panda1.8.1

I tried forcing the installation of panda1.9_1.9.0 (dpkgi -i --force-depends) but upon trying to run the hello world program it complained of not being able to find panda3d.core. Which I attributed to the deb not linking against libc (I have no idea if that’s the case or not).

So I thought I’d try panda1.8.1. After compiling it’s deb also complained of the unmet dependency, however upon forcing this time the hello world program worked.

Still unsure of what went/is wrong, hopefully I will not encounter problems later.

If it could help you, these are the steps I use to build panda from git in debian (wheezy/jessie) and ubuntu (trusty):

  • Get source package:
$ git clone
  • install dependencies from distribution (for panda with bullet and librocket):
$ sudo apt-get install pkg-config libeigen3-dev libswscale-dev \
    libfreetype6-dev libgl1-mesa-dev nvidia-cg-dev libode-dev libopenal-dev \
    libopencv-dev libvorbis-dev libssl-dev python-dev libxxf86dga-dev \
    build-essential git autoconf automake libtool checkinstall gnulib gdebi \
    libglu1-mesa-dev freeglut3-dev libx11-dev libxxf86vm-dev \
  • build with these commands:
 $ cd panda3d
 $ makepanda/ --verbose --everything \
 	--threads 2 --optimize 3 --installer --no-ffmpeg --no-fftw

-install the package:

$ sudo gdebi panda3d1.9_1.9.0_amd64.deb

NOTE: to integrate bullet and librocket you should install (before panda) the packages getting them from their git repos ( or, if you want, you could intall them from my custom git repos (where sources are the same as original ones and quite updated, and only build system is changed to my own based on autotools), following these instructions:

-install the ‘GNU Autoconf Archive’:

 $ git clone git://
 $ cd autoconf-archive
 $ ./
 $ ./configure --prefix=/usr
 $ make maintainer-all
 $ sudo make install

-install Bullet:

 $ git clone
 $ cd my_bullet3
 $ autoreconf -i -v
 $ mkdir build-release
 $ cd build-release
 $ ../configure --enable-demos
 $ make
 $ sudo make install
  • install libRocket:
 $ git clone
 $ cd my_librocket
 $ autoreconf -i -v
 $ mkdir build-release
 $ cd build-release
 $ ../configure --enable-python --enable-samples --enable-extra-samples
 $ make
 $ sudo make install