solved with fresh inst: import direct.directbase.DirectStart


hi, I am using debian testing, my default python version is python2.5. to use sample programs with panda3d it is required to install python 2.4 so I installed both of them.

I tryed to start the fallowing example of the manual

import direct.directbase.DirectStart

it ends up with the fallowing output from the command line

engin@debian:~$ cd Desktop/
engin@debian:~/Desktop$ python2.5 
Traceback (most recent call last):
  File "", line 1, in <module>
    import direct.directbase.DirectStart
ImportError: No module named direct.directbase.DirectStart

if I try to run it with python 2.4 I get the fallowing output from the command line and a blank python window screen.

engin@debian:~/Desktop$ python2.4 
DirectStart: Starting the game.
Warning: DirectNotify: category 'Interval' already exists
Known pipe types:
(all display modules loaded.)
*** glibc detected *** python2.4: double free or corruption (out): 0x084ea4a0 ***

The latest versions of panda3d use python 2.5, not 2.4.
You should first download the latest version of Panda3D that uses python 2.5, and then run programs with python2.5 instead of python2.4, I’d even recommend to completely remove python 2.4.

EDIT: Wait a minute, you did install Panda3D first, didn’t you?

I downloaded the panda3d_1.5.2-deblenny_i386.deb (56 M) when I try to install lenny deb package, dpkg aborted because python2.4 wasn’t installed. so I installed it.
I previously have the 2.5 version of the python. so both 2.4 and 2.5 have to be installed. I cannot remove python 2.5 because it effects my system. lots of programs depending on it.
later I decided to installing panda3d_1.5.2-debetch_i386.deb (57 M) but it didn’t worked also. the similar error messages camed.

quite odd linux is free of window’s python dll hell problem.

Can you check for a panda3d.pth file? It should be somewhere in /usr/lib/python2.5/site-packages.

:slight_smile: many thanks all of you for paying attention. I did’nt replied yet because I have been re installing my system some other problems etc.

With a fresh install it worked with my lenny. But still it is required to install python2.4