[SOLVED] Win7 x64: fatal error C1900

Using the 1.8.0 source, VS2008 SP1 on Win7 x64. I’m trying to do a 64-bit build, but get this linker error:

linking dynamic library built/bin/libpanda.dll

fatal error C1900: Il mismatch between 'P1' version '20081201' and 'P2' version '20080116'
LINK : fatal error LNK1257: code generation failed

I’m using the 64-bit thirdparty directory from here:


If I understand this right, the problem is that my linker or compiler is not exactly the same as the version used to generate some of those libraries…? Do I need to use VS 2010 instead of 2008 for this?

ps - is there another command prompt for Windows that’s not so … uh … primeval? you know, like Konsole, XTerm, whatever the Gnome terminal thing is, OSX terminal, etc. It would be super great to have modern advanced tricks like making the window wider. And copy and paste. Maybe Windows 8 will have those new features?

Install the latest updates for VS 2008 (latest service pack etc.), clean the “built” directory and try again.

thanks - I tried that but I’m still getting the same error. I installed the VS 2008 SP 1 update and additional updates from Windows Update, but no joy.

building with --nothing works fine. but I don’t want --nothing, I want --everything! :slight_smile:

Then that does mean that the thirdparty packages were compiled for a different, incompatible version of MSVC. Perhaps you should e-mail David and ask him for the version of MSVC he compiled it with.

By trial and error I narrowed it down and it turns out it was just libsquish. I downloaded the source and recompiled that library and solved the problem, so I now have a 64 bit windows build of Panda 1.8.

Actually other than that, the rest of the process was completely smooth.