[SOLVED] packp3d / Runtime does not appear to be installed


I’ve installed the 1.7.2 version of the panda3d sdk on my development machine and tried to package a little example.
When I try to execute the packp3d executable it just says: The Panda3D Runtime does not appear to be installed!


The Panda3D Runtime does not appear to be installed!

PANDA located at C:\Panda3D-1.7.2
You must specify the --dir option.

packpanda usage:

  --dir x         Name of directory containing game
  --name x        Human-readable name of the game
  --version x     Version number to add to game name
  --rmdir x       Delete all directories with given name
  --rmext x       Delete all files with given extension
  --fast          Use fast compression instead of good compression
  --bam           Generate BAM files, change default-model-extension to BAM
  --pyc           Generate PYC files


My example and the sdk examples run fine without any problems. Even the packpanda file recognizes the sdk path without any problems?

I’ve reinstalled the sdk several times without any success. Do you have any other suggestions I might try?

You should install the Panda3D runtime. This is a separate installation from the SDK.

You can find this installation under the “Download” tab above, called “Web runtime”.


Thanks David,

I installed the web runtime (I thought the web runtime is only being the part for the web engine of panda3d, my fault sorry) and after invoking packp3d it successfully downloaded additional files and created the p3d file.

This web page and the Panda3D manual don’t do a good job of making that clear. It should probably be called “Panda3D runtime” above instead of “Web runtime”. Also, probably installing the SDK ought to automatically install the latest runtime; most other SDK’s work that way.