[SOLVED]Installing Panda3D on Ubuntu 12.04 Bheta


#1

Hello Folks,

I’m trying to install and use panda 3d, so that i can run another program, named Tethical (a TBS engine, based on FFT, with support for online matches).

Anyway, the problem I’m facing here is that when I try to run the server for Tethical, this error message pops up:

Now, I have already looked through the forums searching for initlibpandaexpress but I found only 3 matches and none of then seems to have a conclusive answer to the problem, other than “You screwed up during installation. Try again!” and “initlibpandaexpress wasn’t compiled with the Python interfaces”.

Now, I do believe that the compilation without the interfaces is the cause of the problem here, but I don’t have a clue what this mean. I’m inexperienced with Python, and I only know some fundamentals about it. I know what an Interface is but I don’t know how could I check if the file got this interface in it’s binaries.

Also, about the installation process, I’m using makepanda, in contrast to the other forum topics, where users where trying to install it with ppremake.

And for some data about what/where I’ve been doing this:

I’m using a x64 distribution of the OS.

I’m building panda with the makepanda.py --nothing flag.

Any help or insight on the subject would greatly be appreciated.

Sorry about my rusty english :stuck_out_tongue: and Thanks for your help and time spent reading my post.


dependency problems installing Ubuntu 12.04.
Fedora 19 installation problem
#2

After going through some forums searchs, I found out that I can’t run the samples that were distributed in it.

The reason behind it is because I choose –nothing at pandamake, and because of that, some essential libraries (for the samples) were left out.

I went through the process of trying it again, but with –everything but this resulted in a lot of warnings in my screen, saying i don’t have some third party libraries.

I also noticed that one of the warnings mentioned zlib, so I checked If i had this package installed. For my surprise, it WAS installed, and even the dev package was also installed.

So, the thing is, how does pandamake checks for the libraries I currently have installed in my system?

Btw, I’m trying to install version 1.7.2 of Panda3D. Maybe I should try 1.8.0 or the one directly from the repositories…

Anyway, thanks for your attention on this matter.


#3

Alright! :smiley:

Here is the deal. For Ubuntu 12.04, I’d recommend installing the 1.8.0 version of Panda3D, and do it with the –everything --installer option.

This method won’t generate any error messages and can find the packages installed in your OS (no more zlib trouble).

As for me, I had do manually remove the files that installpanda.py had created. After this, I just did what I stated before.

Best luck to you.


#4

You can add the --verbose flag and makepanda will explain which files it is checking for presence of libraries such as zlib. Make sure you install the devel version of the packages, eg zlib1g-dev or libz-dev, or whatever it is called.


#5

I’m using Fedora 19 and Panda 3D 1.8.1 but I have the same error,

ImportError: dynamic module does not define init function (initlibpandaexpress)

I have tried with 1.7.2, 1.8.0, .1.8.1 and the RPM but can’t install. Anybody can help please?


#6

You did not compile with Python support enabled. When you run makepanda, it’ll tell which packages are missing. You’ll probably want to install at least the development package of Python in order to use Panda with Python bindings.


#7

You say the Python developer library? https://apps.fedoraproject.org/packages/python-devel
I already have installed python-devel, and tried run with python and ppython but don’t work. Could explain more? thanks


#8

You had the package already installed while compiling?


#9

which package? I tried install the rpm package but show some dependency errors.


#10

If you’re on Ubuntu, you shouldn’t try to install a Fedora package. You should go to your package manager and install “python-dev”, alongside other packages that you want to compile with support for.


#11

Reinier, he stated he uses Fedora, so this is fine. I am sorry I can’t really help - this is one of the few ‘popular’ distros I have never tried.


#12

In Fedora I already have installed python-devel which is equal python-dev in Ubuntu. but the error continues.


#13

OK, I assumed he used Ubuntu since the thread title says “on Ubuntu 12.04”. Please make a new thread for a new problem in the future.

If you run makepanda with --verbose after the --everything --installer flags, it will tell you at the beginning why it thinks Python is missing on your system - what does it say?