[SOLVED] image texture creates problem for mayaPandaTool

Good Morning all,
Ive got a weird issue happening with the mayaPandaTool.mel script.

I am using Maya 6 and my process is as follows:

[b]Model in Lightwave- UV too,

open in Polytrans (with the UV & image still intact)—export out to a .obj & mtl file[/b]
Open that in maya. When its open the model is intact the UV & image are all good. The I use the mayaPandaTool and it runs but no egg is exported…

what I have found out is if I take out the image ref in polytrans and just create a blank obj file (no texture image map) then open that in maya again…I can successully export an egg file…so thus it is the texture that creates the problem.

I have tried .jpgs and .pngs but they make no difference. Do I need to add the image texture in maya? Any ideas? Thanks for any help.

Well, as always, no details, no clue…
Try open the script editor, and export again. See what the error is in script editor.
Details, details, any details as detail as possible. :slight_smile:

I wish there were more details I could give…
Lets see…
I am using the Graphical front end for mayaPandaTool (I drag the mel script in the program window)
When a model is loaded into Maya without any textures (just a mesh) and I use the mayaPandaTool and get the message in the command s cript window (Finished exporting [.mb ->.egg] ) …and then I can see the .egg file and it can load in PView—it is also the default grey of maya without a tex.

When I load the exact same model, with the same mayaPandaTool options going and export it. It DOES take about 4x longer before I get the same message Finished exporting [.mb ->.egg] in the command script area …but there is no .egg file created.

Those are the only things that are displayed…I get no errors or anything, textures and .mb files are in the same location because in maya my model looks fine
The model is triangulated…the textures are PNG or jpg I am not familiar enough with maya to see how the texture in maya IS mapped as it displays in maya fine so I am thinking it should export fine?..

The only difference is whether the model has texture info attached to it or not…it seems as though the mayaPandaTool just cant create the .egg file?

Thanks for the quick reply though ynjh_jo


Suffice to say I solved this issue.

Well, ynjh_jo, reading your post made me look further into the details of what I was doing.

So any of you Polytrans users can see what I didnt know.

Well I was using maya as my exporter…since I like the graphical front end (i though am not familiar with the shading system). Anyway Poltrans opens up my model and exports out a .OBJ and .MTL file which maya can read.

In maya it opens up perfectly. UV intact, model correct, image displays perfect etc. It is using the default texture to place my uv map on it. At this point I run the mayaPandaTool to export. It runs but no .egg file is created.

I looked at ynjh_jo’s answer in thread https://discourse.panda3d.org/viewtopic.php?t=1410&highlight=maya+textures

I guess when maya opens up a UV’d model and though it displays correctly the exporter doesnt want to take the default shader into account…you have to remake a new one and assign it to the model…I followed the instructions in the thread by ynjh_jo…then it worked!

Thanks! :wink: