[Solved] Autocompletion for Panda3D in VSCode

Hi,

Autocompletion doesn’t work for Panda3D 1.10.11. in VSCode 1.68.1. Is it possible to solve this problem?

syntax-hightlighting-for-panda3d-in-vscode

syntax-hightlighting-for-panda3d-in-vscode-typing

I think the thing is that panda comes as libraries .pyd, most likely you should specify in your editor the search paths for libraries.

1 Like

I have this information:

This problem is caused by the lack of .subs files in panda3d package, not vscode. Related problem has been raised in GitHub. Please wait for the update of package.

It was given by MingJie-MSFT on StackOverflow.

unware:

You can download the folder types-panda3d/src/panda3d-stubs at master · WMOkiishi/types-panda3d · GitHub with https://download-directory.github.io/ , name it panda3d-stubs and add the directory containing it to the VSCode’s settings.

"python.analysis.extraPaths": [
        "C:\\Users\\user\\Documents\\panda3d\\stubs"
]

For example:

    "python.analysis.extraPaths": [
        "E:\\Libs\\panda3d"
    ]

image

image

image

Microsoft is always coming up with innovations that simply shift their problems to others. I think VSCode should have a tool to generate such files, as it needs them.