[SOLVED]1.9 Compile error on linux

I’ve tried with this command:
python3 makepanda/makepanda.py --everything --no-opencv
And i’ve got this error @ 93%:

[ 93%] Linking dynamic library built/panda3d/ai.so
[ 93%] Generating 'pandac' tree
Importing code library: panda3d.core
  Found extensions for class: VBase3
  Found extensions for class: VBase4
  Found extensions for class: HTTPChannel
  Found extensions for class: Mat3
  Found extensions for class: NodePath
Importing code library: panda3d.physics
Importing code library: panda3d.fx
Importing code library: panda3d.direct
  Found extensions for class: CInterval
Importing code library: panda3d.vision
Importing code library: panda3d.skel
Importing code library: panda3d.egg
Importing code library: panda3d.ode
Traceback (most recent call last):
  File "built/direct/ffi/jGenPyCode.py", line 94, in <module>
  File "/home/mehdi/Programming/Python/3D/Panda3D/panda3d/built/direct/ffi/DoGenPyCode.py", line 328, in run
  File "/home/mehdi/Programming/Python/3D/Panda3D/panda3d/built/direct/ffi/DoGenPyCode.py", line 260, in generateNativeWrappers
ImportError: /home/mehdi/Programming/Python/3D/Panda3D/panda3d/built/lib/libpandaode.so.1.9: undefined symbol: dBodyGetNumJoints
Storing dependency cache.
Elapsed Time: 2 hours 3 min
The following command returned a non-zero value: /usr/bin/python3.3m -B built/direct/ffi/jGenPyCode.py -r panda3d.core panda3d.physics panda3d.fx panda3d.direct panda3d.vision panda3d.skel panda3d.egg panda3d.ode
Build terminated.

What can i do now?

Hmm, something must be wrong with your ODE installation. If you don’t need ODE for physics (we support several other physics engines), the easiest way out is to add --no-ode to the command-line.

python3 makepanda/makepanda.py --everything --no-opencv --no-ode worked for me.

Please note that Python 3 support is still very new and experimental in Panda3D, and there might still be some issues. We officially only support 2.7, but you’re welcome to try Python 3 support and let us know of any issues.