So installing this is a pain?

I have to admit this is why I don’t like using engines made by other people. It’s useful to boost the project but it is a pain to get working and learn all the new functions. Rant aside:

So this wont work because I am using pyhton 2.6.5 instead of python 2.5?

Right now I’m getting (after 50 different error messages on my command prompt): “Import Error: can not
find libpandaexpress.dll”

Help would be appreciated.

I am pretty sure the current Panda uses python 2.6.x. I am using 2.6.5 and Panda is working fine. What seems to be your problems is that the Panda library is not in your system path so it can’t find any of the .dll’s or other engine specific code.

That’s the thing it was initially telling me it could not find “ShowBase” (I am trying the very first tutorial copy pasted btw). And I guessed that was because the command prompt was not using the python of Panda3d. I fixed this by putting the ‘panda.pth’ file in my python directory (that I use. A lot. For every other python programming I do actually). But now it is telling me it can’t find the library is as far as I’m understanding…I don’t.

I am assuming you are using windows correct? If so Panda comes with its own python that should work out of the box.

Yes I am using windows sorry for not mentioning that.

I have also installed my own version of python over the original.

And it isn’t working. Normally I am referencing Panda’s python anyway so no, it isn’t working right out of the box.

It’s been a while since I used Panda on my windows machine and currently I am not home so I can’t test it out. From what I remember I would run my Panda code from cmd but before running the script I would always cd into the directory of the Panda python and then run my code. Also you might have to add the Panda /bin (I think there are others you might have to add) to the system path for cmd. If you still can’t get it to work I will hop on my windows machine when I get home and post back here with what I had to do to get it working.

Have you tried replacing python with ppython in the commandline (just a try)?

That could also be it. Lol I forgot all about that, but yea try that out and what I recommended also.

Attempting to run ppython instead of python in the command prompt makes no difference (it never seems to what is the difference between those commands).

And how am I supposed to run the file my program is on when I am in a completely different directory?

There are some fundamental things you need to understand about running Panda and Python. If you misunderstand these points initially, you will just cause yourself heartache.

(1) Panda is a compiled C++ Python module. This means it is compiled specifically for one particular version of Python and it will only run on that particular version of Python. (You can make it run with a different version if you need to, but that means you will need to get Panda from source and compile it yourself, which is not recommended if you’re not already familiar with building large C++ programs.)

This is why Panda ships with its own version of Python, to reduce confusion. You (probably) can’t install a different version on top of this one. It is likely to cause problems if you do. You have to use the version of Python that came with Panda. (All right, you don’t have to, but that’s the place to start. If you want to use a different Python, you should be prepared for a bit of trouble.)

(2) Don’t put panda.pth in your python directory, unless you know what you are doing. This is going to cause you heartache if you mix-and-match Python versions, because it won’t work. It will give you errors about not being able to find libpandaexpress.dll. But see below.

(3) The difference between “python” and “ppython” is that “python” is whatever version of Python you happen to have on your PATH. It might be Panda’s version, or it might be any other Python you have installed. “ppython” is a special program to find Panda’s version of Python specifically. Out of the box, “ppython” is supposed to work. If it doesn’t, something went wrong when you installed Panda.

(4) Once you have “ppython” working, then you can talk about getting a different installation of Python working with Panda. To do this, you have to first make sure that it is the same version of Python as the one that Panda uses. That is, if you type “ppython” it will say “Python 2.6.2” or whatever. Make sure that when you run this other version of Python, it also says “Python 2.6.2”. (Actually, the third number doesn’t matter as much, but the first two certainly do. It must be exactly Python 2.6.x, no other version of Python will work. Python 2.5.x won’t work; Python 2.7.x won’t work.) Once you have made sure that the versions match, then you can (a) put panda.pth in the python directory, and (b) if it’s not already there, add the c:\Panda3D-1.7.2\bin directory to your PATH.


My mistake I wrote something I didn’t mean to.

what are you running via cmd? is it this?

C:\my\program\dir\> C:\Panda1.x\python\ppython.exe

Okay what hobbit wrote just worked. Damn that is a pain to type in all that to run the program. Anyway thank you all for your help.

This should also work:

C:\my\program\dir\> ppython

If it doesn’t, but running it with full path does work, it probably means ppython isn’t in your path. The installer should do that automatically, though - you might try just uninstalling and re-installing again.