sh: ldd: command not found

When I run this on my linux box:

ppackage -i built deps.pdef

With deps.pdef:

from sys import path


class deps(package):

    config(display_name='Radakan dependencies')



I get this output:

:Packager: Reading deps.pdef
sh: ldd: command not found
sh: ldd: command not found
sh: ldd: command not found
sh: ldd: command not found 
sh: ldd: command not found
sh: ldd: command not found
sh: ldd: command not found
Generating deps/linux_i386/

Does it matter? And if so, what can I do about it? I’ve tried to make a simlink form /usr/bin/ldd to /bin/ldd, but that didn’t make a difference.

Edit: I’ve been able to make a p3d file using deps.pdef.

Can you run ldd from the shell correctly?

Yes, I can.

bump. I have the same issue. I made symbolic links in /bin and /usr/local/bin with the program itself in /usr/bin

Ubuntu karmic 64

Is the /usr/bin directory on the PATH in /etc/environment ?


Does it work if you do this:

import os
os.system("ldd --version")

Does the ldd version show up correctly? Or do you get a command not found error also?

Version pops up just fine


drwr, do you perhaps have an explanation what could be different about the way the Packager invokes ldd?

It’s certainly mysterious.

The os.system() attempt, did you just run it in python interactively, or did you attempt to package it up and run it in a p3d file? Because I don’t think it would have worked in a p3d file, unless you had also specified “-c keep_user_env=1” on the command line.

The p3d runtime normally blows away the system path, except when keep_user_env is set in the p3d file (as it should be for ppackage). Maybe that’s failing for some reason?


Yup, works just fine as script, but packed into a p3d ldd not found. Here is my sys.path from inside the p3d

[’/home/croxis/.panda3d/hosts/runtime.panda3d.org_96a0ec538744def6/panda3d/cmu_1.7’, ‘/home/croxis/.panda3d/hosts/runtime.panda3d.org_96a0ec538744def6/openal/cmu_1.7’, ‘/home/croxis/.panda3d/hosts/runtime.panda3d.org_96a0ec538744def6/morepy/cmu_1.7’, ‘/home/croxis/.panda3d/hosts/runtime.panda3d.org_96a0ec538744def6/models/cmu_1.7’, ‘/home/croxis/.panda3d/hosts/runtime.panda3d.org_96a0ec538744def6/panda3d/cmu_1.7’, ‘lib/’, ‘lib/python2.6/’, ‘lib/python2.6/plat-linux2’, ‘lib/python2.6/lib-tk’, ‘lib/python2.6/lib-old’, ‘lib/python2.6/lib-dynload’, ‘/mf’]

How about if you use “-c keep_user_env=1” on the packp3d command line?


Nope, no dice

So, we’re narrowing in on the problem. What is the sys.path in this case?


Did not change.