When I apply ambient occlusion via:
self.filters = CommonFilters(,

I get these errors:
GL error 0x506: invalid framebuffer operation
and when I enable gl_debug #t
I get:
GL_INVALID_FRAMEBUFFER_OPERATION error generated. Framebuffer bindings are no framebuffer complete.

I am using the latest build for 65 bits windows: Panda3D-SDK-1.10.0pre-bdb53b8-py3.6-x64

Is there something specific in the settings that I should have used to enable ambient occlusion?

Could you share information about your GPU? Giving the output with “notify-level-glgsg debug” set would be helpful and contain all the relevant information.

debug.txt (16.3 KB)Its a Geforce GTX770, 2 GB

I added the output of notify-level-glgsg debug

The main reason setAmbientOcclusion doesn’t work in my setup is that I use:
threading-model Cull/Draw

Other filters work with this threading model (in my setup), but ambient occlusion does not.

1 Like