Samples won't run

I just installed Panda3D and the only sample I can run is Procedural Cube. All other samples give errors like not being able to load a model or a shader file.

Any help would be greatly appreciated.

How exactly did you run them? What errors did you get? On what platform are you?

I ran them using the “Run …” shortcut that appears in every sample folder.

As an example, here are the errors from the Shadows sample:

The file “caster.sha” is in the Shadows directory.

I’m using Windows XP. I have a GeForce 8600GT with relatively new drivers.

Panda’s filenames are case-sensitive, because that makes it easier for people to keep their code platform-independent.
So, in the terminal, you "cd’-ed into “c:\program files” while you should have cd’ed into “C:\Program Files”.

Thanks, that fixed it.

BTW, I didn’t use a terminal. I just double-clicked on the shortcut icon. To fix this, I had to go to the shortcut’s properties and make the change you mentioned in the “Start in” line. I guess I’ll have to do the same for the other shortcut icons.

Slightly unrelated, but I saw a forum post that said that you have to use the Python version that comes with Panda3D to run any Panda3D programs. Is that true? Because the manual says you can use whatever version you have if you just setup the paths correctly (I’m currently having a problem with this, but I should probably post it on a new thread).

You can use different copies of Python, but you have to make sure it’s the same major version number - Panda’s windows build is compiled against Python 2.5, so you can’t use it with Python 2.6.