Runtime error

Hi everyone, it’s my first post here. I hope that’s the right section.

I have installed Panda3d software on windows. I tried to execute example’s programs and they run.

Then, I configured microsoft visual studio 2008 to develop my application. But, I have an error when I try to run. The error is: “msvcr80.dll missed”, then I download this file from internet and I put it in C:\Windows\System32, but now I have another error: Runtime error, R6034 “an application has made an attempt to load the c runtime library incorrectly”.

I yet install .Net Framework 3.5, and service pack1.
My operating system is Windows 7 Ultimate.

How may I resolv?

Thank you :slight_smile:

P.S. Sorry, for my poor English :frowning:

I’m just guessing here, but maybe your project settings are incorrect? Make sure you set your project to use the same runtime library that Panda uses, which is I think “multithreaded DLL”.

Also make sure that you are building a Release project, of course, and that you have removed NDEBUG from the define list.


Thank you David for the answer.

My project sets to use DLL multithread (/MD) by default, is it the same of Panda’s one?

And I have removed NDEBUG from the define list. (I also tried to write #undef NDEBUG to do it but I have the same problem)