Runs but :display:gsg:glgsg(error): : invalid enumerant

After running the Panda3D installer for a freshly git cloned and compiled 1.9.0 dev source code set, I am getting an error printed to the console for the “Hello World” example. I do get the “Hello World” Panda3D grey window displayed though.

I am taking a totally newbie shot-in-the-dark here based on a similar error with Java’s “lwjgl”. It was an enumeration error for opengl in java’s “lwjgl”. It regarded my “video card” (onboard chip actually) which does not have pixel shader hardware and the lwjgl library doesn’t return a false or -1 for a non-existant pixel shader version, it returned and exception.

Googling Pand3d and :display:gsg:glgsg(error) gave results where some alluded to video card drivers (impling better support for pixel shaders) and others suggesting to not using opengl in Config.prc but to use the other renderers instead. Has my investigation led me in to not use opengl due to lack of pixel shaders (on this system)? I ask this because I am pretty sure I ran the Asteroids example through the browser on the web fine before this machine had a crash and full reinstall of the os (and all).

Line containing app = MyApp() produces the error message.
Python module name:

from direct.showbase.ShowBase import ShowBase
class MyApp(ShowBase):
  def __init__(self):
app = MyApp() # produces message on stderr

Error without “gl-check-errors #t” in Config.prc it produces this:

Known pipe types:
(all display modules loaded.)
:display:gsg:glgsg(error): at 2824 of
: invalid enumerant
: An OpenGL error (invalid enumerant) has occurred. Set gl-check-errors #t in your PRC file to display more information.

Error with “gl-check-errors #t” in Config.prc it produces this:

Known pipe types:
(all display modules loaded.)
:display:gsg:glgsg(error): at 1931 of
: invalid enumerant

Dell Pentium 4 3.2 Ghz
MS Windows XP SP3
Python 3.4.2 32bit
Panda3D dev source 1.9.0 with thirdparty folder containing Python 3.4.2 in win-python subfolder.
Video card is onboard Intel 82865G which does not support any Pixel Shader versions (but has Direct X 9.0c support). No updated video drivers available for a few years now, which is to say the latest is loaded.

In Config.prc
I’ve tried

works but sends enumeration error

load-display pandagl


load-display pandadx9


load-display pandadx8


load-display pandagles


load-display p3tinydisplay

Bug report submitted.