Running p3d Issue

Wasn’t sure where to post this but I made a p3d file successfully and when I run it, it loads a bunch of stuff and then just hangs there and shows the panda with glasses image. The last thing it outputs before it hangs is:

:stuck_out_tongue:ackageInfo: Package numpy uses 15 MB
:AppRunner: Total Panda3D disk space used: 132 MB
:AppRunner: Configured max usage is: 2048 MB

Anyone have an idea what could be going on, or maybe how to enable a verbose mode that can tell me more?


Look in the log file, which is in your AppData/Local/Panda3D/log folder.


Ok this is what the log file said. I could not find anything that looked like a problem or an error, but I also don’t know what I’m looking for.


That log file looks normal. It looks like it’s launching your program, which isn’t doing anything.

By chance does your program have code like this:

if __name__ == '__main__':
  # do stuff

? If so, there’s your problem: in a p3d environment, name is not ‘main’. Take that bit out.


Hey Thanks that totally worked!

though you wouldn’t happen to know why I’m getting this error when it try’s to display radio buttons.

“IOError: Could not load model file(s): [‘models/gui/radio_button_gui’]”

Add “-r models” to your packp3d command line to pick up the standard Panda3D models.


Sweet things work thanks for the help dude.